Rasa X chat only working in strict conversation mode

@JiteshGaikwad I’m currently facing an issue in RasaX in which the bot is able to reply only when in strict conversation mode. In normal conversation mode, I’m only getting a ‘…’ by the bot, and not the repsonse.

Saw that you also faced the same issue. How did you overcome this?

hey @sanjay1983 can you share the screenshot of the issue, actually I am not able to recall the issue. :slight_smile:

Here are some screenshots

! It comes as the bot is typing, but then it quickly refreshes automatically to the following screenshot shown below. All this is in regular conversation mode. Screenshot%20(31)|690x388 !

If I use Strict conversation mode, then it is working as shown below, but I have to manually click on buttons to approve that the bot is indeed classifying intents correctly and so on.


I want to have a normal conversation with the chatbot in the regular mode. Doesn’t seem to be working. :frowning:

Which version of Rasa X u r using?


hi @sanjay1983, I also faced the same issue, I just recalled it now :sweat_smile: so I upgraded the rasa x from 0.21.3 to 0.22.0 and it s working now :slight_smile:

Attaching SS for your reference;

It worked, man. Thanks a lot! :slight_smile:

There might be bug in the older version that’s y that error has occurred

1 Like

Hi, the same issue is occurring again. Rasa-x interactive mode is not working and keeps refreshing every time I type something. Tried upgrading, downgrading, nothing seems to be working. Any suggestions?

what version of Rasa-X your are using?

0.22.1 currently.

try to uninstall rasa-x and do the fresh installation