Rasa bot not responding to chat

we have installed the rasa x server in container mode and we are trying to chat from “(Talk to your bot (Interactive Learning)” but we are unable to get any response however we are able to get a response in rasa shell (inside the container).

please find the below screenshot for your reference


I’m experiencing this exact same issue with the quick install script. It had been working, then last week suddenly stopped responding. I tried reverting to a previous model and that didn’t work. I ran the quick install script again to see if an update would fix it, but no luck so far.

can you both share the rasa X versions you are running? Also @javed just to confirm, did you upload and tag a model in Rasa X?

I’m on 0.37.1

i am using 0.37.1 and yes we have uploaded the model

please find below screenshot for your reference

I’m having the same problem and came here to see if others were experiencing the same thing. It was working sometime earlier last week, however.

can you share what versions of rasa x and rasa you were on before? and what rasa version are you on now?

Another q for @javed - can you open the network tab and hit record activity in your browser and post the request that comes in/gets responded to?

I was/am on rasa 2.3.4 and rasa x 0.37.1, but without changing anything it suddenly started partially working again this morning. It is now responding to messages in the chat instead of hanging indefinitely.

However, I have simultaneously been having the issue of rasa x not saving conversations and the NLU Inbox remaining empty. I thought this was connected to the bot not responding to messages, but actually this problem is still unresolved.

I’ve tried the bot multiple times on Telegram and Slack over the past week personally and had another user try it on Slack 10 minutes ago, but although the conversation works fine, it’s not possible to access any of the conversation data afterward.

It’s strange as I haven’t had this issue previously, and I’m not doing anything different.

@mloubser we are getting any error in the network tab

please find the below screenshot for your reference

The conversations screen, NLU inbox, and TTYB have in common that they all require a successful path from Rasa OSS through event broker through event service through DB to display conversations/messages. A channel like Slack does not require this connnection, since the response comes directly from the Rasa OSS instance - if there is no successful connection to the DB, the conversation will not be saved, but the end user will still be able to talk to the bot. See the architecture diagram. I marked it up, the red paths are the ones that might be broken:

When it comes to conversations not making their way to the NLU inbox/conversations screen, the most likely culprit is the event broker - if you’re using a standard set up, that’s RabbitMQ. Check that Rabbit isn’t showing errors, restarting, or running out of memory. I’ve seen too low resources for Rabbit cause problems for a few people recently. The next thing to check is the connection to the DB. Does the event service logs (which are Rasa X logs) indicate successful connection to the DB on startup? Can you fetch conversations from the DB using the API?

1 Like

For now I’ve switched over to using Docker Compose and haven’t run into issues. If it becomes an issue again, I’ll check RabbitMQ first and let you know.

Is there any solution you can give for rasa open source, I’m basically using rasa webchat and socket io connection, previously it was working as expected but when created a whole new setup it’s not responding in webchat whereas responding fine in rasa shell. How to solve this issue?