Rasa x, bot response not showing up until refresh

I am sure I am just missing something, but after training my bot, when I chat with it I can see the thinking / typing symbol show up but I don’t see the responses until I refresh the page.


This bug is sometimes hard to pin down (as you can guess, it doesn’t happen for most users) but we should be releasing a general change to the conversation page that will make it redundant soon. Would you be able to post the most recent call to the list of conversation events from your Network tab in your browser’s developer tools?

1 Like

I am looking at it now, and of course the issue isn’t happening! I haven’t done anything different but it looks like the bot is responding now without having to refresh. I found this to happen after a fresh install.

I have this running on a digital ocean server, used docker install (with stable)

I will continue working with it and when I get the issue to happen again I will post the network events.

I have the same problem trying to run Rasa x via ngrok on Win 10 Pro, testing this with the default bot from rasa init.

When saying ‘hi’, the network log has the following entry:

[{recipient_id: “me”, text: “Hey! How are you?”}]

0: {recipient_id: “me”, text: “Hey! How are you?”}

recipient_id: "me"
text: "Hey! How are you?"

But instead of the text showing up, it’s just “…”.

The ‘latest_message’ field in the ‘me’ events updates from blank to ‘greet’, but it doesn’t say anything about an utter action.

{sender_id: “me”, slots: {},…} active_form: {} events: [,…] flagged_messages: [] followup_action: null latest_action_name: “action_listen” latest_event_time: 1561452612.36503 latest_input_channel: “rasa” latest_message: {intent: {name: “greet”, confidence: 0.9684470891952515}, entities: [],…} paused: false sender_id: “me” slots: {}`

If you hit refresh on your browser does it show up after?

I can get the response that it was attempting to give after I hit refresh.

I noticed that it only happened early on, it’s been running on my digital ocean server and is not giving me any errors now.

It also appears to not be recording my conversations.

Yup, refreshing works when in the normal ‘chat’ interface. The Guest Testing is even weirder, where refreshing itself doesn’t do anything, but then when you send the first message after refreshing, it suddenly replies to the previous message. Accessing the service directly on the host, even through ngrok, doesn’t have the same problem. Maybe this will go away when we move to Docker on a server.

It sounds like it’s a weird bug @gausie mentioned it earlier.

I get the same response as well when using shared chat. It goes out of order as well.

How did you install via pip? I installed via docker on my server, but still having same issues. I think I installed docker with ‘stable’ instead of a specific version. I’m going to maybe reinstall with the latest version instead of stable and see how it goes. I’ve destroyed a few servers and started from scratch a few times one time it worked perfectly without issue.

I’ll report back

Yup, this is just the standard pip install in a virtual environment on Windows. I have yet to test it outside of virtualenv/conda and on other OS’s, but if you get it in a Linux docker, I’d be surprised if that would make a difference.

1 Like

I actually couldn’t get it to run in docker before, they had some error that was preventing it from working. They fixed that, and I did get a stable version that had no errors like the ones we are having. Installing now, will let you know if I notice any changes.

Hi I got the similar issue with rasa X version 0.19.2 . I noticed that, it only happen to guest client when you share the link “guest/conversations/production/TOKEN” . When you log in as “me” user than it is fine. I used docker version.

I have this issue also:

  • Ubuntu 16.04
  • Rasa 1.1.4
1 Like

We have a general solution for this kind of problem that should be landing relatively soon.


Getting what appears to be the same issue this week with rasa x 1.1.5

1 Like

Do you know whats causing it? and/or a band aid I/we could use interim ?

I have the same problem.

I am running Rasa-x on Windows Server 2008 and tried different web browsers to see if that would make any difference, but the problem was always there.

Has anyone found a workaround?

I’m having the same problem when running Rasa X on kubernetes. I started this thread Rasa X CE Kubernetes Issue since I thought it was an issue with my kubernetes deployment but it seems to be related to this bug. Another thing I noticed is that when I refresh the conversation is shown backwards and the /conversations URL does not load anything.

Have there been any updates on this? I still observe this error, using a clean rasa x install on windows 10 in an anaconda environment.

1 Like

Have you found a solution for this problem? I have a similar problem when I try to share my bot with rasa x. The testers have to refresh the window after every single request/response… Could you please share some tips please?

I also came up with this above issue. is this is still open. or found any solution. please let me know

I face similar problem while deploying in docker container. Then i deployed in kubernetes and prior to that i also added the k3s config file in ./bashrc terminal as it asked…


It almost fixed all problems…

I have followed this too. https://rasa.com/docs/rasa-x/installation-and-setup/openshift-kubernetes/