Rasa X bot not replying (0.33.1) (2.02-full)

Hi, I’m using a local server with external DNS and web domain open from port 443 only on Red Hat 7. Listing down what I did:

  1. Installed RasaX using Kubernetes script and tried to configure ssl and https on it. The configuration was done in the terminal, but RasaX stopped working (Issue #1). So I uninstalled and re-installed rasa using docker-compose.

  2. The latest version was installed i.e. 0.37.0 RasaX with 2.3.1 rasa. I also tried 0.37.1 and 0.36.x versions. Wasn’t able to upload responses using the domain.yml file (Issue #2).

  3. Then I downgraded to 0.33.0 with rasa 2.02, and tried 0.33.1 and 0.33.2 flavors. Even deleted all files from /etc/rasa/, I sometime even deleted db folder when the db_migration container start restarting continuously,. and followed all steps to give db access. But the bot isn’t responding after training. image

I think it might have to do something with postgress, but some help would be appreciated.

I’ve checked logs of production container and even communicated with the bot using shell (bash in production container), it works fine. All the other containers are up, healthy and working.

The API calls on the server using curl works perfectly fine, but it doesn’t store the conversation in the db nor show it on the RasaX UI. On the other hand, using the same API call on a different system on the same network cause “curl: (6) Could not resolve host: 'http” error.

Any kind of help is appreciated.

1 Like