Rasa X 0.38 UI not showing any data from GitHub Repo

I followed the Rasa X Docker Compose Installation and deployed my assistant by connecting my GitHub repo to Rasa X 0.38. My VM instance shows the rasa x container has the correct and latest data from my repo under the git/4 directory, however nothing shows up in Rasa X UI.

Some relevant info:

  • first time I am using the spaCy components in my pipeline
  • first time using Knowledge Base Actions
  • first time using Elastic Search
  • manually uploading a model to Rasa X allowed me to use my assistant and everything works with KB and elastic search
  • errors show up when trying to upload nlu.yml files(or any other data file)

Here’s a list of things I’ve tried:

  • connected and disconnected the repo many times but no luck.
  • reinstalled/updated rasa x
  • verified my project layout
  • verified Rasa 2.4.0 and Rasa X compatibility

I’d greatly appreciate any help!!

Can you provide the Rasa X log from the time when you add the repo connection?

I get the impression that you’re mounting the /data directory into the Rasa X container but to be clear, Rasa X does not use the /data directory. It stores the data in Postgres.

1 Like

Hi @stephens , of course. Here is the log right after I connect the repo. There does seem to be an error. rasa-x-gitclone.log (16.0 KB)

Hi @stephens , from the logs I was able to see there was a bug in my nlu data. I was assigning an int to a text slot as seen in the screenshot, so adding quotation marks solved it. Now all my data is in rasa x ui! Thanks for your help!


You should use rasa data validate and do a train locally before checking the project into git.