Rasa X (docker-compose) can only be run via git repository

If I deploy Rasa X via docker-compose, is the only way to load a bot via git? In local mode, I simply run rasa x in the directory where the bot files are. Anything similar in docker-compose version? I realize there is some functionality build into the ui, but not all e.g. credentials.yml file.

I am interested in the answer to this as I am still unable to connect Rasa X to a git repository.

I can connect to github repo. git00 , git01

BTW what operating system are you using (with version)? I am using ubuntu 18,04.2 . I cannot install rasax on focal foss 20.04. Problem with Docker in Ansible file. I posted this issue yesterday

You do not need to connect Rasa X to git to start it, load and serve a model, or review conversations. You can upload a model via the API or using the “Update Model” button. You can also create training data directly in Rasa X, or upload it via the API to circumvent using git.

Note also that credentials & endpoints are mounted in to the rasa-x container from the installation directory when using Docker-compose; the ones in your git repository have no influence on these files.

That said, you do need to connect it to Git to annotate incoming messages and save them to training data in a systematic way. Otherwise you’re going to have a very manual workflow and the training data in Rasa X is liable to get out of sync with the training data that’s in the model being served.

Ubuntu 20.04 (LTS) x64 on a Digital Ocean Droplet. Can I go to an older version of ubuntu without having to re-install everything?

Thanks for that info. I can see it’s really worth solving the connecting to git repo issue I have. In case there is anything wrong with my project, I’m trying it with a clone of one of the starter packs (with the origins changed).

Yes, I’d say it is worth it. It sounds like you have a slightly different problem from the OP related to the git connection itself. Could you create a new post for that question please? You can tag me in it.

I’m going to try destroying my Digital Ocean Droplet and rebuilding it with the lower version of Ubuntu before going through all the RASA X installation again. I’ll then try to connect the cloned git repo and see what happens. I’ll post here one way or another, and if I still can’t connect it, I’ll raise a new post as you suggest.

Thank you very much for your support Melinda.

Yes, I have posted also regarding the problem with Ubuntu 20.04. Cant seem to get anything related to rasa/rasax to install … not even locally. Either there is a problem with ansible (Docker) for rasax docker-compose or bazel/dm-tree for rasa and rasa x local. I cant be the only one experiencing this.

But yes try Ubuntu 18.04 Bionic. It works as far as connecting to git … for me.

Thanks for responding!

  1. Have you or do you know someone who can connect to an external channel using rasa x docker-compose e.g. twilio for whatsapp integration?

thanx yxs8495

Hi John, please post your question in a new topic since it’s different from the one being discussed here.

  1. If one uses rasa x docker compose without connecting to a git repo, where is the new data persisted? The docs imply that IVC is needed for training but I can create an intent unconnected. Where is it persisted? thanks john

It is persisted in the Rasa X database - that’s the postgres DB that gets started.

Hi Melinda and John, @yxs8495

I destroyed and recreated my droplet with Ubuntu 18.04 (LTS) x64, installed the latest version of Rasa X and followed all the instructions for connecting a clone of the medicare locator starter pack (with the remotes changed). I still get the same result: “Something went wrong. Please try again.”

I deliberately left the SSH key out of the image. I’ll raise a new post.

Thank you both for your help.