Empty NLU data after syncing to git


I just managed to set up a Rasa X server and I’m noticing that after editing nlu.yml outside Rasa X’s UI, the NLU data page becomes empty, instead of syncing with Git.

Besides that, when I try to circumvent this problem by importing the new nlu.yml I get the following error:

Upload failed

Training data upload failed

It’s weird because Rasa X reports on the version control menu it’s up to date with my repository:

@otmarjr strange, can you share the rasa x version and installation method or any reference link ?

Hello @nik202 ,

I’ve installed rasa x using docker-compose, based on Docker Compose Installation

Currently, my .env file defines the following versions:


Note for Rasa Team Hiya @Juste

This is my third reminder to fix this documentation issue, I hope you remember my previous reminder: Docker Compose Installation

Linked Thread: Rasa X REI - instalation issues - #25 by nik202

I request the team to please update this page or mentioned the Correct Version.

Thanks, Nimit

Hi @otmarjr

There is no installation for Rasa 1.0 based on docker-compose, can you find something in this?

Hello @nik202 ,

Well, I think there still exists an installation for Rasa X 1.0 using docker compose, albeit it is deprecated and there is a warning stating it won’t work for Rasa X 1.1 - which makes me assume it still works for Rasa X 1.0:

Installation page:

Hello @otmarjr, Yes, I’m aware of all the shared screenshots, and not only you many other developers have tried to install rasa X 1.0 whilst using this installation process, but eventually they faced a lot of other issues, so on this I can’t comment much. But, if you need an alternate solution, please do let me know. Cheers.

Hello @nik202 ,

I’ve also tried to install using the REI on this very same server and had no success (I also created a topic here - Cannot install rasa-x with REI neither locally nor on my server - #23 by otmarjr)

Anyway, I’d appreciate instructions on how to properly install Rasa X and use all its features as expected. Could you indicate me this alternative solution?

Hello @otmarjr

I hope and wish you get the help soon :wink:


Do you want to install on server side? if you did it, just chage the version to 0.42.5 Ref: https://rasa.com/docs/rasa-x/0.42.x/installation-and-setup/installation-guide

If you stuck, do tag me.

Good Luck!

Thank you for the link, @nik202 , I’ll give it a try on a different server.

However, I’m worried with the current unstability of Rasa X. If I stick to version 0.42.5, I’ll be opting for a version not actively maintained, based on the warning in the docs. Nonetheless, the up-to-date release seems to be very problematic to run.

Currently I’m trying to create a chatbot to serve as a Proof of Concept here in my organization, and I’m afraid those problems may pop up in the future. Do you know of any position of the Rasa team on all these Rasa X issues?


Hope this helps someone else in the future. Matter of fact, I had a problem in my nlu.yml file, which I did not notice when running locally.

I decided to dig deeper into Rasa logs and after running docker logs --tail 50 --follow --timestamps rasa_rasa-x_1 I could notice that I had some validation problems with my nlu.yml file, which were not specified in the error message presented in Rasa X’s UI.

I solved that just by commiting and pushing my new nlu.yml that passed a rasa data validate test. Then, that screen appeared just as expected :grinning:

Yes, make sense but it’s better than nothing, and you are developing POC/MVP, the support will still be available.

I’d highly recommend and it’s my personal suggestion, stick on the ROS and integrate your bot using some third-party widget, Rasa X is basically used for only Testing and analytical purpose.

I’m sorry, I don’t have any particular person, you can check rasa website.

@otmarjr Great, so you are able to run the Rasa X 1.0.1 using docker? Right?

Yep @nik202 , It worked both on Rasa X 0.42 and 1.0.1 using docker and git. Maybe Rasa X team should work on those errors UI, to best signal them.

@otmarjr great, please close this thread as a solution. Good Luck!