Rasa X 0.26.0

Hi Rasa @community!

We released Rasa X 0.26.0 last Friday :rasasuperhero:

There are a lot of updates, so I thought I would summarize them for you. Check out what’s new…

1) Connect Rasa X to Git-based development workflows

Integrated Version Control is now a core feature of Rasa X with a simplified setup. You can load your assistant into Rasa X via the UI by adding the SSH url of your remote Git repository, specifying which branch you want to use, and copying the public SSH key to the deploy key section of GitLab, GitHub, BitBucket, etc.

Docs: Integrated Version Control

Blog: Connect in Fewer Steps: What’s New with Integrated Version Control

2) Focus on the conversations most likely to need your attention with new filters

All conversations you have with your assistant in Rasa X now show up in Conversations. But don’t worry, they won’t clutter the screen because you can now filter by channel. There are also additional new filters for slots, confidence, and stories not in your training data.

Docs: Review Conversations

Blog: Reviewing Conversations in Rasa X 0.26 | Rasa Blog

3) Tag as you review conversations to pattern match across many conversations

When you are reviewing conversations, you can now use tags via the API to help measure success and tags in the UI to help you track conversation patterns that require human judgement to identify, like instances where users struggled or requested a specific feature.

Docs: Review Conversations

Blog: Using Conversation Tags to Measure Carbon bot’s Success Rate

4) Deploy your assistant in minutes with a setup ready to scale

The easiest way to deploy an assistant is to now use our One-Line Deploy Script that sets you up with a scalable Kubernetes cluster. This method deploys both Rasa X and a production-ready Rasa Open Source container, so you’re ready to go live by loading in your assistant with Integrated Version Control.

Docs: One-Line Deploy Script

Blog: 1. Create a VM & 2. curl -s http://get-rasa-x.rasa.com | sudo bash

5) Forward messages from your existing Rasa assistant to Rasa X

If you are not using Rasa X with your assistant yet, we have made it really easy to connect it to your existing deployment. There is even a rasa export command that lets you send all of your past conversations to Rasa X.

Docs: Connect a Rasa Deployment

Blog: How to Migrate Your Assistant to Rasa X (the Easy Way)

Wait, what’s Rasa X? When should you use it?

Rasa X is a toolset that helps you leverage conversations to improve your assistant. It layers on top of Rasa Open Source and helps you build a better assistant by making it easy to to turn real conversations into training data.

You use Rasa X once you have a minimum viable assistant, one that can handle the most important happy paths. Following “the loop” allows you to build the best possible assistant.

Docs: Improve your contextual assistant with Rasa X

Blog: Rasa Open Source + Rasa X: Better Together

If you have thoughts about how we could improve Rasa X or would be willing to chat about your experience good or bad, let me know at t.dunn@rasa.com! :rocket:

5 Likes

Hi, thank you for all your efforts for improving Rasa :slightly_smiling_face:

Unfortunately, as soon as I updated Rasa X to 0.26, it stopped working :frowning_face: This one is one of the problems I’m facing. Is there any way to downgrade Rasa X on my server?

Hi @tiziano! @Tobias_Wochinger is looking into this :slight_smile:

1 Like

Yes I know he is helping me. I was just wondering if exists a way to downgrade Rasa X on the server

I am trying to create a new user on rasa X 0.26.0 and what I get is

This action is not available
ERROR:__main__:Failed to create user.

Why would that be?

1 Like

Hey @tiziano,

You can downgrade RASA X by follow Update RASA X and replace <rasa_x_version> by the version you want in url.

Example with docker-compose quick deployment :

curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/<rasa_x_version>/install.sh
bash ./install.sh

Hi @labeebee. If you are using Rasa X, you are only able to have one username / password. Or are you saying that you deployed and don’t know your username / password?

Thank you @vivitare. I ran the commands you said, but I still display the 0.26.0 Rasa X UI

That was my first user creation. Thus I switched to 0.25.2 version. I can login and see the dashboard. However, the experimental, Integrated Version Controlling cannot be seen.

@labeebee Integrated Version Control is no longer experimental in Rasa X 0.26, so there is no need to activate it and always in the UI. Are you saying you can’t see it at all?

Thanks for the hard work!

It seems the installer doesn’t support the mac still, I was wondering what were the problems that using a pure docker environment was not able to cover? Last time I looked at the script there were some underlying ansible tasks, so I’m guessing I would need to spin up a clean host to check this out (and then deal with all the issues of connecting remote models etc).

tx

I could find it all. I tried training a model too. Just now I configured the action server as per the lessons in MasterClass Ep 9. However, now when I try to train, Train button doesn’t train a model. instead, a prompt message that says, “Training Started” vanishes and there is no news of any model being built. Last time I trained, the train button was grayed out throughout the training process. Now when it fails, the training button is active and purple.

Hre is what I get when I click train

@labeebee Can you please share your Rasa X logs and the logs of the rasa-worker service?

Please find them here. rasa_worker_log.log (88.3 KB) rasa_x_log.log (42.2 KB)

This is the first time I am trying to deploy a bot, though I have prototype-d a few. I am not very much aware, how I can solve a few of the errors listed, despite I having cleared them when I ran the bot in my local, on the cli. Your help will be much appreciated. Thanks in advance.

Having tried out some suggestions on the forum, here is where I’m. rasax.log (48.6 KB)

Though I see errors like, unrecognized intent, and that I have to add it in the domain file, I can assure you that all of the intent errors are up to date in the domain file. I think the error for the action server to not reply is caused by some errors in the rabbitMQ which I cannot comprehend.

I really like this new feature! Version control from Bitbucket integrated with Rasa X. No more worries about lost work, happy to track differences.

1 Like

Is multiple users an Enterprise feature? Or why is Rasa X limited to one user?

Hi @tatianaf. Yes, multiple user accounts is a Rasa Enterprise feature