Doubt regarding rasa deployment

Version: dev-CC I have deployed Rasa X on a gcloud server according to the docs. Has the Rasa X deployment already deployed Rasa opensource also or do i need to start up another instance for deploying rasa opensource?

Hi @steve! The Rasa X deployment also comes with Rasa Open Source. You can load your assistant into Rasa X using Integrated Version Control and start using it :slight_smile:

Thank you. I activated Integrated Version Control. Does that mean that if I update the credentials.yml in my git repository It will automatically sync or do I have to update it manually?

@steve Integrated Version Control is only for your training data. I recommend checking out (Ep #11 - Rasa Masterclass) Connecting an assistant to external messaging channels to make your assistant accessible to real users via a channel other than share your bot.

I followed the tutorial and tried to connect to a telegram bot but was unsuccessful. After I added the credentials and restarted using docker-compose restart the models I trained disappeared from rasax. Also when I’m not able to train a new model. I have to remove the telegram credentials and restart again to be able to train a model again. I have to add that i did not link a domain name with the VM instance and also it is not using https for that reason.


I got it working after I used an old domain I had and setup https certificates as shown in the tutorial. It would be useful to provide information about how only https works with a telegram bot.

1 Like

I’m having the same problem. I have already set up the certificates like in the Rasa Master Class video #11. I can access Rasa X using the https address, but I’m having the following error messages when telegram is included in the credentials. Also, my models disappear if telegram is in the credenials.

 Starting Rasa X in production mode... 🚀
Traceback (most recent call last):
  File "/opt/venv/bin/rasa", line 8, in <module>
  File "/opt/venv/lib/python3.7/site-packages/rasa/", line 115, in main
  File "/opt/venv/lib/python3.7/site-packages/rasa/cli/", line 337, in rasa_x
  File "/opt/venv/lib/python3.7/site-packages/rasa/cli/", line 396, in run_in_production
    _rasa_service(args, endpoints, None, credentials_path)
  File "/opt/venv/lib/python3.7/site-packages/rasa/cli/", line 100, in _rasa_service
  File "/opt/venv/lib/python3.7/site-packages/rasa/core/", line 189, in serve_application
  File "/opt/venv/lib/python3.7/site-packages/rasa/core/", line 117, in configure_app, app, route=route)
  File "/opt/venv/lib/python3.7/site-packages/rasa/core/channels/", line 92, in register
    app.blueprint(channel.blueprint(handler), url_prefix=p)
  File "/opt/venv/lib/python3.7/site-packages/rasa/core/channels/", line 187, in blueprint
    out_channel = self.get_output_channel()
  File "/opt/venv/lib/python3.7/site-packages/rasa/core/channels/", line 270, in get_output_channel
  File "<decorator-gen-32>", line 2, in set_webhook
  File "/opt/venv/lib/python3.7/site-packages/telegram/", line 67, in decorator
    result = func(*args, **kwargs)
  File "/opt/venv/lib/python3.7/site-packages/telegram/", line 2242, in set_webhook
    result =, data, timeout=timeout)
  File "/opt/venv/lib/python3.7/site-packages/telegram/utils/", line 333, in post
  File "/opt/venv/lib/python3.7/site-packages/telegram/utils/", line 244, in request_wrapper
    raise BadRequest(message)
telegram.error.BadRequest: Bad webhook: failed to resolve host: name or service not known

My credentials.yml file looks like this (I replaced the real values of access_token and webhook_url):

   url: ${RASA_X_HOST}/api

  access_token: "my access token"
  verify: "robyn_test_bot"
  webhook_url: ""

I have used this telegram bot before using Rasa Open Source and it worked fine using ngrok. Now I’m trying to deploy it and am coming across these issures. Anyone have any ideas?