Rasa Webhook URL Not Found

When I tried to access the following URL:

http://localhost:5005/webhooks/facebook/webhook, I received the following error:

[2019-06-30 16:48:40 -0700] [19832] [ERROR] Exception occurred while handling uri: ‘http://localhost:5005/webhooks/facebook/webhook’ Traceback (most recent call last): File “c:\users\rasa.conda\envs\rasa63019\lib\site-packages\sanic\app.py”, line 893, in handle_request handler, args, kwargs, uri = self.router.get(request) File “c:\users\rasa.conda\envs\rasa63019\lib\site-packages\sanic\router.py”, line 407, in get return self._get(request.path, request.method, “”) File “c:\users\rasa.conda\envs\rasa63019\lib\site-packages\sanic\router.py”, line 469, in _get raise NotFound(“Requested URL {} not found”.format(url)) sanic.exceptions.NotFound: Requested URL /webhooks/facebook/webhook not found

What step did I miss? I ran Rasa as follows:

rasa run -m models --enable-api --log-file out.log

1 Like

Hi @ManyChat

does your credentials.yml contains something like:

#  verify: "<verify>"
#  secret: "<your secret>"
#  page-access-token: "<your page access token>"

as stated out here:

Did the command line printed out the statement of loading the default credentials.yml? If not, you need to use:

rasa run -m models --credentials credentials.yml --enable-api --log-file out.log

Did that help?



@JulianGerhard that was exactly what I needed to do.

I did include this also

–endpoints endpoints.yml

as well and uncommented

#  url: "http://localhost:5005/webhook"

it as well. To help everyone else here is the full command I used after I uncommented endpoints.yml and I set-up the credentials.yml for Facebook: I used this for my Anaconda Windows 10 setup for those wondering the environment.

rasa run -m models --credentials credentials.yml --enable-api --log-file out.log --endpoints endpoints.yml

For others, if you used docker, it was:

docker run -v $(pwd):/app rasa/rasa run -m models --credentials credentials.yml --enable-api --log-file out.log --endpoints endpoints.yml

One last note is that Facebook Webhook only takes “https” so when you run ngrok on your local install, they provide you both http/https.

@JulianGerhard @akelad i tried to connect messenger to my rasa chat bot but still got error

raise NotFound(“Requested URL {} not found”.format(url)) sanic.exceptions.NotFound: Requested URL /webhooks/facebook/webhook not found

I’m using this rasa run --credentials credentials.yml command for run please guide me.

@DiJay2229 hi, what are the contents of your credentials? Also, welcome to the community!

I’m running in to the same issue.

rasa --version => Rasa 1.9.5 in WSL2 environment with conda

1 Like

@smartexpert I am facing the same issue while integrating chatroom with Rasa. @akelad Please guide me

Facing the same problem right now, the bot worked fine over the past two days, out of the blue this just popes up.

Can anybody help ?

hi, could you both post some more details please? Rasa verison, error shown, credentials configuration etc

hi i am facing the same error while trying to implement a form using custom actions

@Akhil1278 could you please post some more details? what Rasa version are you on, what does your endpoints.yml file look like

Hey that problem is resolved actually but i am facing other problem with slots


Would be great if you can open a new topic for this issue, so as not to get off track on this one.

Hi @Akhil1278,

Would you kindly describe how you solved the issue please?


1 Like

@Akhil1278 Hi, I’m facing the same issue, it would be nice if you could share you experience and help to solve the issue please.


Guys any update on this issue??..I am also facing same issue but with teams…if anyone got any lead please let us know. Thank you.

I exposed the port of my computer while running the container: -p 5005:5005, and it worked.