Slack webhook not found

Im trying to set up a slack channel for the first time.

I added it to my credentials.yml like this:


  slack_token: "hidden"
  slack_channel: "hidden"

  url: "http://localhost:5002/api"

But when slack tried to verify the url I see this error in Rasa:

raise NotFound("Requested URL {} not found".format(url))
sanic.exceptions.NotFound: Requested URL /webhooks/slack/webhook not found

Previously the “rasa” credential was commented out but I uncommented it because i saw that suggested in another thread but it didnt help the issue…

Wow I just changed /webhooks/slack/webhook to /slack/webhook and it worked…

Hi Tatianaf

We are trying to integrate our Rasa assistant with Slack but without NGROK. How can we do that? Can we provide “http://localhost:5005/slack/webhook” without doing any tunneling? Appreciate your input here.


Another note for rasa travellers encountering this on their journeys:

In the credentials.yml file, you may have an entry at the bottom, which is used for rasa-x, designated as rasa: localhost:5002/api

Updating this setting to localhost:5005/api (the rasa port, instead of rasa-x port) resolves 404 webhook errors on other endpoints.

Hope that helps someone :slight_smile: