Rasa is not responding to user message

Rasa version : 1.2.7

The context

I am facing an issue. I run Rasa X with the following command :

rasa x \
    --no-prompt \
    --enable-api \
    --rasa-x-port 5000 \
    --port 5001 \
    --cors "*"

After server has successfully started, I can do without any issue :

  • Go to Rasa X interface
  • Interact with Rasa X API
  • Interact with Rasa API (/GET /version, /GET /conversations/{conversation_id}/tracker and /POST /conversations/{conversation_id}/messages are the endpoints I tested and that are working fine)

The issue

So my problem is that /POST /webhooks/rest/webhook on localhost:5001 is returning the following error :

Error: Requested URL /webhooks/rest/webhook not found

Here is the logs of the server :

[303] [ERROR] Exception occurred while handling uri: 'http://localhost:5001/webhooks/rest/webhook' 
Traceback (most recent call last):
  File "/opt/app-root/lib/python3.6/site-packages/sanic/app.py", line 893, in handle_request
    handler, args, kwargs, uri = self.router.get(request)
  File "/opt/app-root/lib/python3.6/site-packages/sanic/router.py", line 407, in get
    return self._get(request.path, request.method, "")
  File "/opt/app-root/lib/python3.6/site-packages/sanic/router.py", line 469, in _get
    raise NotFound("Requested URL {} not found".format(url))
sanic.exceptions.NotFound: Requested URL /webhooks/rest/webhook not found

What I have tried to resolve my issue

I have tried to run Rasa server only with the following command :

rasa run --enable-api --port 5001 --cors "*"

And /POST /webhooks/rest/webhook on localhost:5001 is successfully responding.


What’s wrong with this endpoint request on Rasa API when run by Rasa X ? Am I missing something or is it a bug ?

Thanks in advance

Solved, was missing credentials.yml file

1 Like