Rasa shell behaving completely differently than rasa interactive

Hi there,

I’ve been working on a chatbot these past few months and it worked fine, so I was ready to turn in my project. Before handing it in, however, I wanted to quickly test the “rasa shell” function as well - so far, I’ve only been using rasa interactive (to make it possible to directly correct errors in the prediction). Unfortunately, I was up for a nasty surprise: With rasa shell, my bot behaves completely differently from what I’ve trained it to do - it doesn’t listen when it is supposed to, it doesn’t follow the rules that I’ve programmed … I have no idea what I did wrong. As I said, it all worked perfectly fine in rasa interactive, I used the same model, the same virtual environment with the same rasa version … (rasa 3.3.1, rasa-sdk 3.3.0)

What could I be doing wrong? I read somewhere that the problem might be that the model isn’t loaded correctly, but how do I check that?

I’m really frustrated - as I said, I was about to hand in my project … Obviously it’s my fault that I didn’t test rasa shell earlier, but it didn’t think I would have to because I thought that I trained my bot in the interactive mode in order to make it work in the live version …

I’m grateful for any kind of help!

EDIT: I’ve just tried running my assistant using an older model with the command rasa shell --model \models\<name_of_model>.tar.gz and got the error message “The path … does not seem to exist”. Did I get the command wrong or is this part of the whole error and therefore relevant?

Hello there,

this path is probably wrong. Did you mean models/<name_of_model>.tar.gz ?