Rasa Installation always halting at tensorflow installation

Hi everyone,

I’ve been trying to install Rasa yesterday and today but have been facing many issues.

If I clone the git repo as required, move into the rasa foler, and do pip install -r requirements.txt, my installation always halts at the tensorflow 1.13.1 installation. (See picture)

If I do pip install rasa-x --extra-index-url Simple Index as shown in the installation guide, it halts at building dependencies. (See photo).

I was first trying with Python 3.7 but downgraded to Python 3.6.8 and it still doesn’t work. The above happens.

Even running ‘pip install rasa’ halts. First time it halted at tensorflow like the above, now it is halting at ‘Collecting colorclass~=2.2 (from rasa)’ (see photo).

Any help is greatly appreciated. Thanks!


Hi @alihejazi! Some questions:

  • Have you installed Microsoft VC++ Compiler, so python can compile any dependencies?
  • Have you tried following the TensorFlow install guide?
  • What version of pip are you using?

@tyd Pip version 19.1.1 Yes I have installed the Microsoft VC++ Compiler. And yes I have just tried the TensorFlow install guide. In doing so I came across this error: (it halts at “Installing setuptools, pip, wheel…” then I press Ctr+C to exit it.

@tyd all of this is on Windows 10 btw

@alihejazi Are you using a virtual environment (anaconda or something else)? Have you tried with a downgraded version of pip?

@tyd Yea I just tested with anaconda… halts at ‘Collecting tensorflow’… I feel this is the central issue. Just confusing why it still doesn’t work.

The problem still happened earlier today with an earlier version of pip and continues to happen with the upgraded one.

Some extra context which might help you: yesterday initially when I was trying to install rasa using “pip install rasa-x --extra-index-url https://pypi.rasa.com/simple”, it wouldn’t halt at ‘building tools’ like it does in my 2nd screenshot (at the top). Rather, It would open and process in another cmd window, throw the VC++ error and then immediately close.

@tyd VC++ Compiler is installed on my machine

I find the MINGW64 output in your terminal a bit confusing. Are you actually sure that the VC++ compiler is used by your python instance? Maybe do a python -VV and check the output. MINGW is not compatible with newer python versions.

@Tobias_Wochinger doing ‘python -VV’ gives the following output: “Python 3.6.8 (tags/v3.6.8:3c6b436a57, Dec 24 2018, 00:16:47) [MSC v.1916 64 bit (AMD64)]”

Not too sure to be honest… does that raise any flags for you or no?

No that actually looks good :+1: Any idea where the MINGW thing comes from in your terminal?

@Tobias_Wochinger Not sure. Don’t worry about. I switched to a Mac… problem solved :joy: :rofl::rofl:

Oh dear :smiley: Would be great to hear if others experience the same problem or if it was a unique case :thinking:

@Tobias_Wochinger @alihejazi I have the exact same problem and followed all the steps as @alihejazi. Please help

Personally I don’t know. What worked for me was switching to a Mac, but I know that Rasa also works on windows, but I don’t know how to get out of that error. Perhaps you did some initial incorrect installations, I don’t know; I believe that’s what had happened with me. Maybe try to uninstall everything and start again from scratch?

I’ll try to do that. Thanks

You’re welcome