Installation failing - tensorflow 1.10.0 not found

Trying to install Rasa on a new machine and it’s failing - pip can’t find Tensorflow 1.10.0.

Looking on PyPI, Tensorflow has been upgraded to 1.11.0. That would seem like the reason, though I’m no expert on how pip works (or why it’s not possible to access the previous version now). A few questions:

  1. Should this be raised as a bug/feature on Github? Happy to do so if appropriate.
  2. Does anyone know if Rasa will work with TF 1.11.0?
  3. Is this kind of thing documented/covered elsewhere? Couldn’t find it, but don’t want to be adding noise if so.


I am having the same issue

Could not find a version that satisfies the requirement tensorflow==1.10.0 (from rasa_core) (from versions: )

No matching distribution found for tensorflow==1.10.0 (from rasa_core)

Unable to get RASA going.

Apparently this is an issue with Python 3.7 being too new. How do you use an earlier version of Python to get it working?

1 Like

I replaced python 3.7 with 3.6. Now I am getting another:

Command “python egg_info” failed with error code 1

I followed a solution I found online and upgraded set-up tools

pip install --upgrade setuptools

And now I am getting YET another error:

Could not install packages due to an EnvironmentError:


And why is it referring to version 2.7 above?

There is a known issue with Python 3.7 and Tensorflow. It’s to do with the async keyword being introduced iirc, which causes some name clashes with Tensorflow. I haven’t found anything that says if/when Tensorflow will be made 3.7 compatible. As you note elsewhere though, the Rasa issue isn’t specific to 3.7; install still fails with 3.6 & below due to the Tensorflow version bump.

And why is it referring to version 2.7 above?

Just a thought: you might need to use pip3 instead of pip. I don’t use a mac. But some linux distros use Python 2.x as default (used internally for scripting). To use 3.x you need to specify it explicitly: so pip3, python3, … That might explain the 2.7 error message.