RASA 3.7.8 incompatibility with certain packages like langchain

Hi All,

I am trying to install Langchain version 0.0.354 with RASA 3.7.8 and somehow there are some incompatibilities that i see. Below is the log related to it:

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
langchain 0.0.329 requires langsmith<0.1.0,>=0.0.52, but you have langsmith 0.1.22 which is incompatible.
rasa 3.7.8 requires openai<0.29.0,>=0.28.1, but you have openai 1.13.3 which is incompatible.
rasa 3.7.8 requires packaging<21.0,>=20.0, but you have packaging 23.2 which is incompatible.

is there any solution to this issue?

regards, Mayank