Packages Issues in RASA

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

tensorflow 2.3.1 requires numpy<1.19.0,>=1.16.0, but you’ll have numpy 1.19.2 which is incompatible. rasa-nlu 0.15.1 requires cloudpickle~=0.6.1, but you’ll have cloudpickle 1.4.1 which is incompatible. rasa-nlu 0.15.1 requires jsonschema~=2.6, but you’ll have jsonschema 3.2.0 which is incompatible. rasa-nlu 0.15.1 requires matplotlib~=2.2, but you’ll have matplotlib 3.3.2 which is incompatible. rasa-nlu 0.15.1 requires packaging~=18.0, but you’ll have packaging 20.4 which is incompatible. rasa-nlu 0.15.1 requires ruamel.yaml~=0.15.7, but you’ll have ruamel-yaml 0.16.12 which is incompatible. rasa-nlu 0.15.1 requires scikit-learn~=0.20.2, but you’ll have scikit-learn 0.23.2 which is incompatible. rasa-core 0.14.5 requires fbmessenger~=5.0, but you’ll have fbmessenger 6.0.0 which is incompatible. rasa-core 0.14.5 requires jsonschema~=2.6, but you’ll have jsonschema 3.2.0 which is incompatible. rasa-core 0.14.5 requires packaging~=18.0, but you’ll have packaging 20.4 which is incompatible. rasa-core 0.14.5 requires pika~=0.12.0, but you’ll have pika 1.1.0 which is incompatible. rasa-core 0.14.5 requires python-socketio~=3.0, but you’ll have python-socketio 4.6.0 which is incompatible. rasa-core 0.14.5 requires pytz~=2018.9, but you’ll have pytz 2020.4 which is incompatible. rasa-core 0.14.5 requires redis~=2.0, but you’ll have redis 3.5.3 which is incompatible. rasa-core 0.14.5 requires ruamel.yaml~=0.15.0, but you’ll have ruamel-yaml 0.16.12 which is incompatible. rasa-core 0.14.5 requires scikit-learn~=0.20.0, but you’ll have scikit-learn 0.23.2 which is incompatible. rasa-core 0.14.5 requires slackclient~=1.0, but you’ll have slackclient 2.9.3 which is incompatible. rasa-core 0.14.5 requires tensorflow~=1.13.0, but you’ll have tensorflow 2.3.1 which is incompatible.

I am getting all the error messages when I install Rasa X on my machine. is there a way to resolve this?

Regards, Ayush

1 Like

Hi @asing218. Which version of Rasa OSS do you have installed on your machine?