Packaging version conflict with RASA and Langchain

Hi All,

I am integrating RASA with external LLM. While doing so, I am facing version conflict issues. Rasa wants packaging version >=20, <21 while langchain wants packaging version <24.o, >23.2. How to resolve this?

Error messages:

ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts. langchain-core 0.1.32 requires packaging<24.0,>=23.2, but you have packaging 20.9 which is incompatible.

ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts. rasa 3.6.15 requires packaging<21.0,>=20.0, but you have packaging 23.2 which is incompatible.

Please help. Thanks in advance.