Problem running rasa with ssl-certificate

Hi, I am trying to tun rasa using command rasa run --ssl-certificate myssl.crt --ssl-keyfile myssl.key --ssl-password mypassword

I am passing the certificate and key along with password to this command but I am getting an error rasa run: error: invalid choice: ‘rasassl.crt’ (choose from ‘actions’)

I am using the latest version downloaded from github.

Is it a self-signed certificate?

@Gehova yes it is a self signed certificate.

Is it because of that? If I pass it the other one will it work?

For what channel? Does it have a documentation for self signed certificates?

For example, telegram has it in its webhook guide:

@Gehova I am using REST channel for accessing rasa

I am trying to run rasa using command-

rasa run -m models --enable-api --endpoints endpoints.yml -p 5005 --ssl-certificate myssl.crt --ssl-keyfile myssl.key --ssl-password mypassword

Try a pem certificate created like:

openssl req -newkey rsa:2048 -sha256 -nodes -keyout <mykey>.key -x509 -days 365 -out <mycertificate>.pem -subj "/C=<Country>/ST=<State>/L=<City>/O=<Organization>/CN=<Your IP>"

An try running rasa with the following command:

rasa run --log-file out.log --ssl-certificate <mycertificate>.pem --ssl-keyfile <mykey>.key --port 443

Port 443 is the default for https. I’m not sure how to handle the REST channel, because according to the documentation, it doesn’t require credentials.

HTTPS , but requested an insecure XMLHttpRequest endpoint ‘http://:5005/conversations/default/respond’. This request has been blocked; the content must be served over HTTPS . i installed rasa server in ubuntu it is working fine locally when i hosted in https server it is giving

Fixing mixed content

@rajeshpolaki you got any solution for it? i’m facing the same issue. please let me know if you come with any solution. Thanks.

@rashmi_49 i installed another server in that server i configured SSL certificate and through reverse proxy i configured and errors are not coming

socket url to be changed to https://ipaddress then it may resolve u r problem

@rajeshpolaki

i installed another server in that server i configured SSL certificate and through reverse proxy i configured and errors are not coming

Can you help me understand about this another server? and how did you configured SSL certificate?

@rashmi_49 hi can u share u r configuration i mean rasa version and os what u r using any apache server using or using nginx let me know so that i will guide u in fixing the bug if possible share the screen shot how u r runnig rasa run command: --enable_api & --cors “*” let me know if any issues feel free to ask and i will do my level best to fix the bug

@rajeshpolaki Sorry for that, Yeah so I’m using latest Rasa Version: 2.2.5, Rasa SDK Version : 2.2.0, Rasa X Version : 0.35.0, Python Version : 3.8.5, Operating system: ubuntu 18.04, And i’have deployed my chatbot on a local server and ussed command for running the rasa server is

rasa run --model models --enable-api --cors “*” --debug

and for action server i’m using

rasa run actions --actions actions -vv

also i have connected my chat-bot to a website by using the IP of my local server in the index.html of the front end. Now what issue i’m facing is that , The website to which the chat-bot is connected is using SSL and i’did’t knew at at time that rasa don’t support HTTPS request so after shutting the SSL at that webpage we are abble to get the response from the bot because the request is not being block at rasa server. What i want to do is somehow i want to add SSL funtionality at the rasa server end for which i thought i should use Nginx and i followed the step of this blog TTT Studios | Making a Lightweight, Low-Cost Rasa Chatbot with NGINX but got not clearity on how to set domain name and what to do next to achieve a way for reverse proxy and configure SSL in rasa chat bot. it will be very helpful if you can help me. sorry that i can not share my code for some policy reasons. but i’m trying to explain my problem as simple as i can. thanks for helping.