Getting error while running rasa server with ssl certificate

Hi, I am using rasa open source and rasa webchat interface. While I am trying to run rasa server on my website:, I am getting this error.

I am getting the response “Hello from Rasa: 1.10.0” when I open this link(https://ip_address:5005) in the browser directly but when I try it integrating with website, I am not getting the chatbot icon and getting the error as shown in the attached .txt file. See the attached file for the whole error. Can anybody help me to resolve this error. Thanks. Chatbot Error.txt (128.7 KB)

hi @devesh ! looks like an error with sanic trying to handle the SSL certificate. What does your credentials.yml file look like? (please don’t post any secrets in the forum, though)

@amn41 , I have not changed anything in credentials.yml. Just using the default one. If you want to see it, I have attached it here. credentials.yml (1.0 KB)

Hey @devesh, could you share your credentials.yml and also the configuration of the webchat widget?

Hi @akelad, my webchat widget configuration and credentials.yml file are as attached :

webchat_config.txt (620 Bytes) credentials.yml (1.0 KB)

Hi @akelad and @amn41, sorry to write you again but did you find any solution to this problem?

Hi @devesh, sorry about not getting back to you sooner, things have been a bit crazy with prepping L3 AI. I’m not 100% sure what’s going on here. But I will say that the way you’re loading up an ssl certificate is actually intended for securing the communication between containers, rather than acting as an SSL cert for your VM. I would suggest using something like nginx to handle that.

Rasa X comes inbuilt with all this, if you haven’t checked that out yet

Thanks @akelad for the help. The issue is now resolved. The issue was basically due to some ip address mapping. I don’t know about it too much but IT team of my company solved it. Thanking you again for providing support.

I am using a ssl server to deploy rasa. It is running without any errors and the domain at which rasa server is running is also responding with “Hello from Rasa: 2.3.4” but when I try to connect rasa webchat with this sever i get the error:-> Access to XMLHttpRequest at ‘https://#####.com/socket.io/?EIO=3&transport=polling&t=NW1Tvyv’ from origin ‘https://#####.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Please give me a solution …stuck with this issue for a long time.

Note: This issue is happening only for ssl servers.