Problem facing in integrating bot with Google assistant

Hi , I was following the below link and cloned the project i.e Place finder for integrating to Google assistant. Strictly followed every step in the tutorial but at the end when i am trying to test the bot on test simulator i am getting error attached below. I may be missing something a help will be greatly appreciated.

Thanks!

link –

Going beyond ‘Hey Google’: building a Rasa-powered Google Assistant

Issue -

Hey @NikhilBansal21. Oh, I think this is a bit annoying behaviour from Google testing side. I would suggest trying the following:

Go to permissions of your project on Google Actions console and add a new user with viewer permissions (you will need a different google account for that).

image


Once you do that, login to the account that has viewer permissions and you should be able to test you assistant. Alternatively - ues the Google Assistant App on your phone for testing.

Hi @Juste, I faced the same problem, followed your advice and managed to talk to the bot using simulator console in the browser with another google account with ‘Viewer’ permission. However, I still cannot make it work using Google Assistant App on my phone. Even though I speak the same words that activate the Rasa bot in the simulator (ok google, talk to …), the Assistant only searches for ‘talk to …’ in google. I tried both google accounts and it doesn’t work on either of them. Do you have any idea how to fix that?

Hey @maciej. Hmm, that should work… are you looged in using the same account as you used to test it using the simulator on the web?

Thanks for a quick reply @Juste. I managed to solve the problem. It worked after I turned on web & app activity in google activity controls. Now I’m facing a problem with not being able to activate google assistant with locked screen using bluetooth headset, but it seems that it’s a common problem on many phones. Anyway, everything else works fine now, thanks for help!

That’s good to hear! :slight_smile:

Hi every , I am also get the same error like

Even i am trying giving a viewer permission to another username and checked out on that account. But still same error. What is the problem

Thank you

Hi @Bunny99, which version of Rasa are you using? if you are following this (Going beyond ‘Hey Google’: building a Rasa-powered Google Assistant ) blog, in step 5 how are you loading models to rasa nlu interpreter and agent.

Hi @yeshwanth .Sorry when I am running “run_app.py” it is showing a n error

C:\Users\Pulivarthi\Bluemix\tutorial-rasa-google-assistant-master\place_finder>python run_app.py c:\windows\system32\rasa\rasa_nlu_ init .py:12: UserWarning: The ‘rasa_nlu’ package has been renamed. You should change your imports to use ‘rasa.nlu’ instead. UserWarning, C:\Users\Pulivarthi\AppData\Local\Programs\Python\Python36\lib\site-packages\h5py init _.py:36: FutureWarning: Conversion of the second argument of issubdtype from float to np.floating is deprecated. In future, it will be treated as np.float64 == np.dtype(float).type . from ._conv import register_converters as _register_converters Traceback (most recent call last): File “run_app.py”, line 3, in from custom import GoogleConnector ModuleNotFoundError: No module named ‘custom’

How to solve that error…

Hello, I’m facing this problem while integrating with Google Assistant

I am trying to connect an already existing Rasa bot. Please help me on this issue

try this. U can replace the run_app.py

tutorial-rasa-google-assistant/run_app.py at master · RasaHQ/tutorial-rasa-google-assistant · GitHub

That’s the same file that I have, still the problem persists

if you use rasa 1.0 , try using the new tutorial form here . It’s working well for me.

Hi, I’ve been trying to integrate rasa with google assistant. I followed this tutorial.

The only difference is that I didn’t configure anything in credentials.yml and I don’t even include ga_credentials.yml file as I don’t require any of google apis. I tried giving access to some other user and trying with that account. It didn’t work.

I’m running rasa in my server which is already publicly exposed, so I’m not using ngrok. When I invoke the action, it says my action is not responding. I could see some exception raised in the server where I run rasa. Below is the snapshot:

[2019-12-30 07:06:16 +0000] [11681] [ERROR] Exception occurred while handling uri: unknown Traceback (most recent call last): ** File “/home/ubuntu/rasa/rasa-env/lib/python3.6/site-packages/sanic/server.py”, line 273, in data_received** ** self.parser.feed_data(data)** ** File “httptools/parser/parser.pyx”, line 193, in httptools.parser.parser.HttpParser.feed_data** httptools.parser.errors.HttpParserInvalidMethodError: invalid HTTP method

I guess the request from google assistant reaches the server, but there should be some problem in parsing the request in rasa side. Am I missing anything else? image|419x492

Please help me address this issue to integrate rasa with google assistant!

Follow tutorial carefully and include below line in credential.yml

ga_connector.GoogleConnector:

Make sure you set path of current project as mentioned in tutorial.