Problem deploying rasa using quick install script

I am facing an issue while trying to install rasa through quick install script.

The quick install command, upon running in an ec2 instance terminal, doesn’t terminate. The terminal sets stuck at “Deploying Rasa X …”

I am using the following command.

curl -s | sudo bash

Also, I noticed that the certificate of the webpage is expired which might be a potential cause of the issue.

If you do kubectl get pods --namespace rasa, are all the pods running?

It happens to me sometimes. Deployment script gets stuck but the pods are running.

Yes! All pods seem to be running. But I get “404 page not found” when I try using rasa X via deployment URL.

Note: I could access Rasa X via URL when I deployed the assistant using the quick install script about 15 days back. This issue started occurring when I tried redeploying the assistant yesterday on the same instance.

1 Like

Really weird. Did you try deleting the whole namespace with kubectl delete --namespace rasa?

Yes I did. That doesn’t change anything.

@nik202 kindly look into this issue as well as I have not been able to solve this yet.

@gaushh Sure! can you please share the installation link you are following? and which rasa x and rasa open-source version you are planning to install?

I was initially trying to install: RASA_X_VERSION=0.42.5 and RASA_VERSION=2.8.12 by setting environment variables.

But since it didn’t seem to work, I tried out the default versions too without any environment variables.

Installation link:

curl -s | sudo bash

To debug, I put the quickinstall script contents in a shell script and ran it manually. Looks like it is getting stuck at the following place in the script:

wait_for_deployment_to_be_healthy() {
  echo "check 3"
  # Get the Rasa X pod name
  POD=$(kubectl --namespace "${DEPLOYMENT_NAMESPACE}" get pod -l -o name)

  # shellcheck disable=SC2016
  # Check the Rasa X health endpoint to be sure that the deployment is ready and the Rasa X is fully operational
  # The Rasa X health endpoints returns status 200 if the rasa-production and rasa-worker services are ready
  # The endpoint is checked inside of the rasa x pod in order to avoid dependency on an ingress configuration
  kubectl --namespace "${DEPLOYMENT_NAMESPACE}" \
    exec "${POD}" -- /bin/bash -c 'curl -s localhost:$SELF_PORT/api/health | grep "\"status\":200"' &> ${REDIRECT}

When I terminate the script myself, all the pods seem to be running and I can’t see any anomaly in logs but the URL renders 404 page not found.

Upon running kubectl logs -l

I get No resources found in rasa namespace.

@gaushh Which method you are using quick install or docker-compose on server site installation?

Quick install

@gaushh please share the documentation link of which Rasa X version you are trying to install?

@gaushh are you comfortable with docker-compose installation?

@gaushh ??

No, I’m not comfortable using the docker-compose installation method and would prefer if I get a solution to this only.

@gaushh ok then please delete the quick installation and start a fresh one.

What is your server its Ubuntu or I can give you online assistant if you like?

@gaushh your issue resolved? I hope so. If yes please close this thread as solution. Thanks.

1 Like