Policy could not be loaded

Hi, I update the rasa version from 1.7.1 to 1.9.3. When running “rasa train”, policy could not be loaded. But 1.7.1 is OK. Any help,thanks.

rasa 1.9.3 ubuntu 16.04 tensorflow 2.1.0 or tensorflow1.14.0 both tried

Which policy?

Keras policy. Because the first policy in my domain file is keras policy. the every policy could not be loaded,

Keras Policy is depreciated, use TEDPolicy instead of Keras.

I tried. It’s the same error “‘TEDPolicy’ could not be loaded”

can you share your config.yml and the error log?


  • name: TEDPolicy #- name: KerasPolicy
    epochs: 1
    max_history: 5
    priority: 1
  • name: EmbeddingPolicy
    epochs: 1
    max_history: 5
    priority: 2
  • name: FormPolicy priority: 3
  • name: MemoizationPolicy
    max_history: 5
    priority: 4
  • name: MappingPolicy priority: 5
  • name: FallbackPolicy
    nlu_threshold: 0.7
    core_threshold: 0.5
    fallback_action_name: action_custom_fallback
    priority: 6

I had the same error with the MemoizationPolicy, what i did was i uninstall the tesnorflow and install it again try using tensorflow 1.15.0, you can do that with pip install tensorflow==1.15.0

OK, it works. Thank you

1 Like

Hi, Glad that helped you can you mark that post as the Solution.