When I run the following install (pip install -r requirements.txt), I get a clash telling me that rasa-nlu expects coloredlogs 9.0 but that 10.0 is installed; a similar issue happens with packaging. The thing is, I did this with a fresh virtual environment and all I did was install rasa-core and rasa-nlu to the current latest versions (core : 0.13.0, nlu : 0.14.1). I am listing my requirements below.
This doesn’t seem problematic for us now because coloredlogs is about coloring logs in the terminal and packaging is about (I think, correct me if I am wrong) unit tests, but we are not doing those yet. But the red error with package versions clashing is definitely not comfortable. How could this be fixed?
setuptools==39.1.0 \ sklearn_crfsuite==0.3.6