No response from Rasa X assistant in conversations Tab

I would like to document resources I am finding as I debug this.

Firstly, there appears to be a bug filed for this behavior: Rasa X - forever no response when chatting · Issue #7629 · RasaHQ/rasa · GitHub

Secondly, there seems to be an old conversation from last year, however the similarity of the described issue doesn’t seem to exactly match my issue. Rasa X not working properly

Things I have tried today:

  • set RASA_HOME environment var
  • switch tracker store to REDIS instead of DB in docker-compose up
  • tried to debug mode rabbit as the pika handoff seems to be where the system stalls, but can’t seem to work out the correct syntax of the command statement for now [rabbitmqctl set_log_level debug] fails

This is where I get up to when the system hangs:

rasa-production_1  | 2021-02-03 01:32:22 DEBUG    rasa.core.brokers.pika  - Published Pika events to exchange 'rasa-exchange' on host 'rabbit':

Restarting the containers seems to bring up messages in the NLU inbox that weren’t in there before - so this could be related to rabbit.

Any additional advice or assistance would be appreciated - thanks! Patrick