[SOLVED] Problem training a model on Rasa X: no responses received


I have the last version of Rasa and Rasa X with an update made today. It is installed on a Ubuntu 18.04 server using docker-compose.

I have built a chatbot using Rasa. I trained the model using Rasa then I tested it and it works very well. Then, I uploaded the trained model to Rasa X and tested it and it works fine. I made a conversation with the chatbot and it responds correctly, both find the intent and provide the corresponding utterance.

Then, I wanted to train the same model on Rasa X. I uploaded the NLU, Stories, and Domain to Rasa X, the started a training. I have activated the new modeled trained on Rasa X.

When I try a conversation with the model trained on Rasa X, it behaves strangely. The first question, it responds fine. Then, when I ask any other question, it determines correctly the intent but does not provide the response. Sometimes it provides a wrong utterance and sometimes it just goes directly again to action_listen without providing any response. I tried several times, but it always give consistently the same thing.

Is there any problem with training with Rasa X? Is there any possible way to solve this problem?

The same data trained with Rasa provides an excellent working model, but when trained on Rasa X, it the problem described above.

I would appreciate any hint in this respect

Thanks Anis

I solved the issue. The configuration file in Rasa X was not correct. I just fixed by copying the same configuration file that I used in Rasa. It works fine now!