Hi all,

I’m having trouble getting MappingPolicy to work. I’ve upgraded to rasa 0.14.1 and I’ve added MappingPolicy to my training ensemble. I’ve also mapped some intents to utters in my domain, as described in the docs, like so:


  • hello
  • start_test
  • thanks
  • kenmerken {triggers: utter_kenmerken}
  • bye

I can train the bot just fine. However, when testing the bot, it maps the intent “kenmerken” to AugmentedMemoizationPolicy. Should I remove the story that contains the utter from my stories file?


What do you mean by this:

It maps the intent “kenmerken” to AugmentedMemoizationPolicy.

Do you mean the Augmented Memo is calling the next action instead of the mapping policy? Is it still predicting the correct action?

Huh, yeah that’s a pretty vague way of putting it. My apologies. I meant that the intent “kenmerken” was consistently handled with AugMemoPolicy. It didn’t use MappingPolicy for that. However, I’ve fixed it as of today.


Fixed it. You have to delete any stories that include the intent you want handled through MappingPolicy.

I’m glad you got it fixed. Still strange though – the MappingPolicy has a higher priority than AugmentedMemo, so if there’s a mapped action, the policy ensemble should favor the MappingPolicy :thinking: