Policy can't be trained properly

story_md = “”"

fqa

  • greeting
  • action_fq_answering
  • action_reset_slots “”"

The above is my story, it only has one story. But I can’t train a policy for it.

I have tried. EmbeddingPolicy, KerasPolicy, Memo, nothing works. It used to work fine. Also that MappingPolicy probably would work, but I can’t find it anymore. I am using the legacy rasa_core 13.2. Someone please help.

The metadata.json does not have any of my actions registered. It only has action_listen. how does it happened?

Hey @XufengXufengXufeng

I remember that I have read, that your bot need to contain at least 2 intents… is this the case? Based on your story it is not…

You might want to try it by adding same sample intents from one of the bots on GitHub to test it…

Regards

Thank you @JulianGerhard

I have tried the bot from the Quickstart tutorial. I got the same kind of error:

I increased the keras epochs and max_history to larger numbers. And the result got a little better.

Are there any other tricks that I can do to improve the core model metrics? It used to be that the NLU model was hard to train but the core model training process works effortlessly. Now, it comes in the other way around in my case.

The increased epochs and max_history solution works. The trained core model can carry my dialogue flows correctly. The confusion matrix looks bad because the rasa_core (0.13.5) evaluate module works not as what i have expected. It creates some intents about “state_” and my model gives wrong predictions. I understand what state_s are for. I don’t need them in my stories. I hope there is a better way to turn the auto create state_ intents off.

1 Like

Ah - glad to hear! I will investigate this too. Thanks for mentioning!