Issue with Cisco Webex Teams Connector

I am trying to use the cisco-webex-teams connector. The setup does not work unless I put the “room” id in credentials.yml file.

Though the documentation clearly states that “If you do not set the room keyword argument, messages will be delivered back to the user who sent them.”

In my case, I am trying to create a bot which anyone in any room can start conversing with. In such a scenario, it is not possible to have the room ids in advance. Also there is no way of having more than 1 room id mapped. So it kind of does not make sense for a bot to be able to communicate only to 1 room.

Is there a workaround? Also, the documentation link referred to in the tutorial no longer exists.

Even i couldn’t find the proper documentation to connect to webex teams. @jchaudhary30, were you able to connect?

I couldnt find any documentation related to connection with webex teams @jchaudhary30 let me know if you are able to connect and documentation looks incomplete in the provided forum

It wasn’t intuitive, but was able to get Rasa working with Webex Teams! Slack was very easy, but conversely Webex Teams took a lot of time to figure out, so I would like to share the steps I used as they were hard to find in documentation. Here’s what I had to do:

  1. Make sure Rasa is publicly accessible (ngrok in my test example)
  2. Create a Webex Teams bot. Overview - Bots | Cisco Webex for Developers
  3. Create a Webex Teams integration for all “messages” types which points to the publicly exposed Rasa url (ngrok) Overview - Integrations | Cisco Webex for Developers
  4. Use a Webex Teams API (with Webex Team bot’s access token) to create a webhook to sign it up for this new Integration you just made. Webhooks - Create a Webhook | Cisco Webex for Developers. Point this url to Now, at this point all message events the bot receives in Webex Teams will be posted to the Webhooks url (publicly exposed Rasa ngrok url). So now we need to make sure Rasa can consuming this incoming Webhooks with its credentials.yml file.
  5. Make sure Rasa credentials.yml has: webexteams: access_token: (Webex Team’s bot API access token) Exactly like documented here: Cisco Webex Teams You can also optionally use “room”, but that makes it so the bot will respond into the room (not the DM). For me personally, I like it better with “room” left out of credentials.yml, but having this option is still great.

Creating the Webex Teams bot AND Webex Teams integration and then signing the bot up for this integration was the piece that took me some time of understand. Once I setup that part with the steps above, it worked great.

Now, when you DM the bot in Webex Teams, it will respond with the Rasa responses. I hope this helps others! Good luck.