Interactive Learning intent dropdown list not working

Hi, I’m using rasa-x 0.28.6 to run my rasa open source version 1.10.0, and I’m having trouble when trying to make training/testing data through interactive learning.

As the title suggests, I can’t seem to be able to switch the intent that the bot predicts for a user utterance. The ‘v’ to the right of the text ‘intent: mood_great (0.39)’ in the picture above just doesn’t do anything. It doesn’t seem to matter what browser I use.

I also can’t edit bot actions.

I’m running Rasa-X using docker-compose, and have closely followed the Docker Compose Installation guide to set it up. I haven’t found any other topics where people have this issue, so I’d be really grateful for someone to help me troubleshoot this. Thanks.

I’ve been trying to troubleshoot this myself recently, and I realized that I am able to change the intent, but not by clicking the dropdown menu button. Instead, if I click on the text, a cursor pops up and I can actually type out a new intent. I’m still not given any options for alternative intents, and instead must type in the intent and hit enter or tab.

Has anybody else experienced this?

There’s a UI issue in that release. Scroll the entire screen down and you will see the list of available intents.

Thanks, that fixed it. The issue also seems to be happening in the newest rasa-x release (0.31.3). Do you know the newest release where it’s not an issue?

1 Like