Install error of rasa-x and rasa under the same venv

After install rasa in venv, I tried to install rasa-x with pip3 which is up to latest version.

sudo -H pip3 install rasa-x --extra-index-url https://pypi.rasa.com/simple

Collecting tensorflow-cpu~=1.15.0 (from rasa<=1.7,>=1.6.1->rasa-x)
  Could not find a version that satisfies the requirement tensorflow-cpu~=1.15.0 (from rasa<=1.7,>=1.6.1->rasa-x) (from versions: )
No matching distribution found for tensorflow-cpu~=1.15.0 (from rasa<=1.7,>=1.6.1->rasa-x)

Any help will be appreciated.

Hi @yiouyou, we recommend you install Rasa X on a server, not locally. Have you seen the Masterclass episode on setting it up yet?

It’s on AWS EC2, not my locally computer. Is this what you mean? @erohmensing

I watched the master classed. As I know, there’re two ways to run rasax.

  1. run “rasa x” in a folder contains pre-trained model, it will give you localhost link; then, use ngrok to generate the public accessible link.

  2. use docker-installed rasax, run “sudo docker-compose up -d” in /etc/rasa, start a rasax server, then upload the model to server through “curl …”

It’s all I know so far. However, besides building rasa model and run it without rasax, I failed almost everytime when tried to use rasax.

I don’t know if it’s because I’m using EC2 on AWS. If anyone can help me figure out why, that will be great.

Yes, the second way is the recommended way to run Rasa X. Where are you getting stuck in deploying it According to the Docker-Compose Quick Install docs?