Install rasa on aarch64


i am trying to install rasa nlu on my orange pi aarch64.

The command I run to install in a virtualenv is the following:

pip3 install rasa == 2.5.0 rasa-sdk == 2.5.0.

The installation fails with the following error:

ERROR: Could not find a version that satisfies the requirement tensorflow-text <2.4,> = 2.3; sys_platform! = "win32" (from rasa == 2.5.0) (from versions: none)
ERROR: No matching distribution found for tensorflow-text <2.4,> = 2.3; sys_platform! = "win32" (from rasa == 2.5.0)

What can I do for you?

Thanks to anyone who wants to give me a suggestion.

Welcome to the forum!

The docs recommend using Windows, macOS, or Ubuntu.

Anyway, please show me the output of pip3 -V in your virtual environment.

Thanks for the reply. But in which architectures can I install rasa? This below is the version of pip.

pip3 -V
pip 20.0.2

I am using orange pi

Is this the full output of pip3 -V?

If not, please show it. If yes, please show me the output of python -V.

You just need AVX.

Run more /proc/cpuinfo | grep flags | grep avx . If you don’t see a result, it means your CPU does not support it.

Hi Chris. Are you interested in working in a rasa project daily for 1 Month? Please contact me

No thank you, I already have a job and I’m a student as well - no time for side projects :slight_smile:

Try posting in the Jobs in Conversational AI category.

The cpu does not support AVX. The cpu does not support AVX

The cpu does not support AVX. Is it necessary for tensorflow and rasa?

Yes it is - unless you want to build Tensorflow from source.

Ok, I’ll try. For rasa 2.5 which version of tensorflow should I install?

I installed tensorflow with the command

pip3 install tensorflow-aarch64

I then installed rasa with the command

pip3 install rasa

I had no mistakes.

running the rasa command, I get rasa mot found

if i run the python -m rasa command, i get the error module not found.

Do I try to compile rasa?

Thank you

Sorry for not answering previously!

Maybe @nik202 can help better? :sweat_smile:

I the meantime, make sure pip3 -V and python -V give you the same Python version. If not, try python3 -m rasa.

pip3 -V
pip 21.3.1 from rasanlu/venv/lib/python3.8/site-packages/pip (python 3.8)

python -V
Python 3.8.10

I installed pip3 install tensorflow-aarch64 and rasa. Now running the python3 -m rasa command I get the following error:

Error while finding module specification for 'rasa.__main__'
(ImportError: cannot import name 'ASA' from partially initialized module 'rasa'
(most likely due to a circular import)

I tried to compile rasa. Running the make install command, I get the following error:

poetry run python -m pip install -U pip
Requirement already satisfied: pip in /home/tbop/src/rasanlu/venv/lib/python3.8/site-packages (22.0.4)
poetry install
Installing dependencies from lock file

Package operations: 64 installs, 3 updates, 0 removals

  • Installing tensorflow (2.7.1): Failed


  Unable to find installation candidates for tensorflow (2.7.1)

  at ~/.local/share/pypoetry/venv/lib/python3.8/site-packages/poetry/installation/ in choose_for
       69│             links.append(link)
       71│         if not links:
    →  72│             raise RuntimeError(
       73│                 "Unable to find installation candidates for {}".format(package)
       74│             )
       76│         # Get the best link

make: *** [Makefile:68: install] Error 1

What can I do? I’m just having trouble installing rasa on orange pi.

@tboprob only one simple question, are you able to install Anaconda on your system, yes or no (please try and get back to me)

Ref: Installing on Linux-aarch64 (arm64) — Anaconda documentation (If you need any help)

Trying to install anaconda, I get the following error: line 408: 20639 Illegal instruction “$ CONDA_EXEC” constructor --prefix “$ PREFIX” --extract-conda-pkgs

@tboprob Ok. If you are not able to install even Anaconda then I’m afraid there is no possible solution from my side as I never personally installed on aarch64. Did the above-mentioned link didn’t help you?

Yes, the link was useful to me. i managed to install conda mac older version. when I run conda istall rasa = 2.5 CondaHTTPError: HTTP 000 CONNECTION FAILED for url if i run a wget of the json from the address, i can download it. I can’t find a solution.

@tboprob do mention me next time.

@tboprob if you are able to install anaconda follow these steps as mentioned in this thread :

Please install Anaconda from Anaconda | Individual Edition , then create the conda environment using the following command

  1. conda create -n rasa2 python=3.8
  2. conda activate rasa 2

PS: If you using Linux, check the environment for the same.

Note: I’d recommend creating a fresh environment if not you can proceed with the next steps:

For Rasa Open Source:

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'


As per your requirements.

check version rasa --version is install or not

For Installing basic project:

rasa init

Do get back to me on this good luck!

To install conda I had to use Miniforge3 conda is now installed and python too conda --version conda 4.12.0 python --version Python 3.9.10

now trying to install rasa

pip3 install rasa, rasa appears to be installed

Requirement already satisfied: urllib3 <1.27,> = 1.21.1 in /home/tbop/miniforge3/lib/python3.9/site-packages (from requests> = 2.20-> rasa) (1.26.9)
Requirement already satisfied: certifi> = 2017.4.17 in /home/tbop/miniforge3/lib/python3.9/site-packages (from requests> = 2.20-> rasa) (2021.10.8)
Requirement already satisfied: idna <4,> = 2.5 in /home/tbop/miniforge3/lib/python3.9/site-packages (from requests> = 2.20-> rasa) (3.3)
Requirement already satisfied: charset-normalizer ~ = 2.0.0 in /home/tbop/miniforge3/lib/python3.9/site-packages (from requests> = 2.20-> rasa) (2.0.12)
Building wheels for collected packages: rasa
  Building wheel for rasa ( ... done
  Created wheel for rasa: filename = rasa-0.0.5-py3-none-any.whl size = 6115 sha256 = d84648c361684c8e7ad6f52efcf99c2a75f7c71a4cc29acb8753d380faf20fad
  Stored in directory: /home/tbop/.cache/pip/wheels/16/9b/e5/589820b8a86bcf14b1020a72bab300d7f853c133075a6f3d72
Successfully built rasa
Installing collected packages: rasa
Successfully installed rasa-0.0.5

but if I run the command rasa --version -bash: rasa: command not found

I tried to install 2.8 with the command pip install rasa == 2.8.1` I get the following error:

ERROR: Could not find a version that satisfies the requirement rasa == 2.8.1 (from versions: 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.1.0, 0.1.1, 0.2 .0a2, 0.2.0a3, 0.14.0a5, 0.14.0a6, 0.14.0a7, 0.14.0a8, 0.14.0a9, 0.15.0a6, 1.0.0a1, 1.0.0a2, 1.0.0a3, 1.0.0a4, 1.0.0a5 , 1.0.0rc1, 1.0.0rc2, 1.0.0rc3, 1.0.0rc4, 1.0.0rc5, 1.0.0rc6, 1.0.0rc7, 1.0.0rc8, 1.0.0rc9, 1.0.0rc10, 1.0.0rc11, 1.0.0rc12, 1.0 .0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9, 1.1.0, 1.1.1, 1.1.2 , 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.2.0a2, 1.2.0a3, 1.2.0a4, 1.2.0a5, 1.2.0a6, 1.2.0a7, 1.2 .0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.2.8, 1.2.9, 1.2.10, 1.2.11, 1.2.12 , 1.3.0a1, 1.3.0a2, 1.3.0, 1.3.1a1, 1.3.1a3, 1.3.1a4, 1.3.1a5, 1.3.1a8, 1.3.1a10, 1.3.1a11, 1.3.1a12, 1.3.1a14, 1.3 .1, 1.3.2, 1.3.3, 1.3.4, 1.3.6, 1.3.7, 1.3.8, 1.3.9, 1.3.10, 1.4.0, 1.4.1, 1.4.2, 1.4.3 , 1.4.4, 1.4.5, 1.4.6, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.6.0a1, 1.6.0a2, 1.6.0, 1.6.1, 1.6.2, 1.7 .0, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.8.0, 1 .8.1, 1.8.2, 1.8.3, 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.9.6, 1.9.7, 1.10.0a1, 1.10.0a2 , 1.10.0, 1.10.1, 1.10.2, 3.1.0)
ERROR: No matching distribution found for rasa == 2.8.1