Increased bot response with increased message history for seder_id

Hello I ran into a performance issue. I have a chatbot and several users who communicate with the bot, but over time, when the dialogue history accumulates, the bot starts to respond for a very long time, but if a new user writes with a new sender_id, the bot will respond quickly. I would appreciate any help. I think the problem is with TrackerStore. I tried to use InMemoryTrackerStore and SQLTrackerStore, but the bot’s response to one sender is constantly growing, and I do not know how to solve this using the standard TrackerStore. I found a solution in creating a custom CustomTrackerStore and specifying the max_event_history parameter, but in this case, not the whole dialog is saved.

I also tried on a simple bot (which is created using the rasa init command) and the time also increases if sender_id does not change.

Hi @Vldub! I think you are looking for conversation sessions, which were released in Rasa 1.6.0. These will allow you to avoid the problems you are having with tracker stores constantly growing

I tried to set session_expiration_time: 1, when the time passed, the response time was still increasing

@vidub Can you please try the conversation sessions with the SQLTrackerStore or Mongo? The performance shouldn’t go up for the in-memory one. Setting the time to 1 is probably not the best idea, maybe try setting it to at least a couple of minutes.

Thanks for your reply, I will try to increase the time and report the results on Monday.

In general, the response time continues to grow, but insignificantly, while there is no better solution, let it work like this)