Illegal instruction error while training NLU

Hi! Guys,

I have installed rasa core and rasa nlu in my virtual machine running with centos. I was trying to run the train command. But when I run I am getting Illegal instruction error nothing else on the screen. Can anybody help me to solve this.


I’m with the same problem, someone could help. I am trying to follow the quick boot tutorial, but when I give the command to train only the illegal instruction message appears. Thank you very much in advance

I am also facing the same issue, is there any bug associated?

I do not know how to report this. One thing I found very strange was the conflict that the installation of rasa-core causes with the numpy version. And when everything seems solved, it just does not work. It’s frustrating, I thought the community was more supportive.

It could be because of AVX architecture absence in the processor. Somewhere i have read that tensorflow=1.5.0 version will work in this scenario.

Our first, thank you very much for the answer, I was already discouraged from getting any help and even considering using another framework. I created another test environment with virtualenv and when I went to install I got the following error:

tensorflow 1.10.0 has requirement numpy <= 1.14.5,> = 1.13.3, but you’ll have numpy 1.15.2 which is incompatible.

The problem is that when I change the numpy version I edit the dependency of the tensorflow, but rasa_core break. I do not know what to do, I thought the installation was simpler.

@will_lima adding people from Rasa Framework

@akelad @tmbo

If you’re getting actual errors during installation/usage please post that as an issue in our github repos. @will_lima i would guess that you can ignore that warning – does the software not run?

wait, the requirement for rasa core is numpy==1.14.5, that’s the one that should have gotten installed. try running pip install numpy==1.14.5

I am also facing same problem over the server running with CentOS-6.7. Even I have observed only rasa --help is working and rest all others {run, shell,version} is giving me error “Illegal Instructions” and nothing more even applied debug option too. I have successfully installed rasa[full]==2.1.2 with Python-3.7.9 in venv which was without any breaks or errors.

What needful should I do to run it?

After a long search in troubleshooting the issue, I concluded it as the system ims not having newer AVS supported CPU due to which I am getting this error.