Illegal instruction(core dumped) Tensorflow

Hello guys , can someone plz help me I just installed rasa from source on UBUNTU and everything went fine but when I wanted to train the model it gives me this error : ILLEGAL INSTRUCTION (CORE DUMPED) and apparently it’s because my CPU doesn’t support AVX so the solution I have is to build it from the source but I’m afraid that the same problem remains can someone please help

Can you share your log with the full error message? Thanks.

There it is , whenever I run a rasa command it throws this error error

Pleease can u check this and tell me what’s wrong , if it’s really the AVX problem ?

Might be related to tensorflow. What version of python and tensorflow are you using?

Python 3.7.5 and tensorflow 2.1.0

As per it seems to be related to AVX support.

Yes, if your CPU does not support AVX (the likely cause for Illegal instruction (core dumped) error) then you need to compile from source. This causes the code to be generated without AVX instructions and then you can use it.

Guess you just need to try to install from source. But not sure about it.

I actually tried to build it from source but it’s quite difficult is there any tutorial that can help me do it ?

You should be able to clone the repo, install poetry, and then execute make install-full.That should install dependencies and the current rasa version.