How to store the conversation with django website if Rasa X is not working?

I want to store the whole conversation and I have django backend. I built it from this official Rasa youtube channel video:

Please tell me how to do that as Rasa X is not being downloaded due to the issue with pip (common issue).


@rhazra-003 Where you want to store the whole conversation? You can store whole conversation whilst using Tracker Stores.

If in case you want store the whole conversation in some databases such as PostgresSQL, My SQL, MongoDB etc please follow the above mention link, Even if you dig more you can even store in Excel or CSV file. If you further need help please message.

Regarding Rasa X it’s not clear with me, can you explain more?

1 Like

@nik202 Thank you! I will go through it.

Regarding Rasa X, I am talking about this issue: python - PIP install rasa-x takes forever - Stack Overflow

This is what I am using in my virtualenv:

(base) C:\Users\rdmhz>conda activate installingrasa

(installingrasa) C:\Users\rdmhz>rasa --version Rasa Version : 2.3.1 Rasa SDK Version : 2.3.1 Rasa X Version : None Python Version : 3.7.4 Operating System : Windows-10-10.0.19041-SP0 Python Path : c:\users\rdmhz\appdata\local\continuum\anaconda3\envs\installingrasa\python.exe

And this is what I get in my cmd:

C:\Users\rdmhz>rasa --version Rasa Version : 2.7.0 Minimum Compatible Version: 2.6.0 Rasa SDK Version : 2.7.0 Rasa X Version : None Python Version : 3.8.3 Operating System : Windows-10-10.0.19041-SP0 Python Path : c:\program files\python38\python.exe

I am also a bit confused why I am getting two different version. Can you help me to sort it out?

@rhazra-003 I guess you have created the environment installingrasa and then install the rasa. Perfect, this approach is fine to make the environment more stable. Check under (installingrasa) C:\Users\rdmhz> pip list or conda list to check the packages or rasa version.

Secondly, I guess you also installed the rasa on the (base) Anaconda prompt?

Check under (base)C:\Users\rdmhz> pip list or conda list.

You will get the clear idea :slight_smile:

That’s, why you getting to 2 rasa versions.

Just stick and work on installingrasa environment and all will be fine.

For installing and run Rasa X follow this video tutorial:

I hope this solution helps you?

For installing rasa x, use installingrasa (VirtualEnviornment) and follow video you will be fine I guess, if not share the error screenshot.

1 Like

@nik202 I did what exactly you said, but It is getting struck here for a really long time.

What should I do now?

@rhazra-003 I will suggest deleting the virtual environment (installingrasa), even delete rasa from conda, there should not be anything related to rasa. If you find it difficult to deleting rasa, delete the Anaconda and install a fresh version. Create a fresh virtual environment and then give it a try, I believe you will able to solve this issue, as I can see it having some compatible issues of versions and packages. Good Luck.

1 Like

@rhazra-003 Are you able to solve this issue?

@nik202 no I tried what you said. Tried on a different conda set up. Still no change.

@rhazra-003 Its strange, did you delete everything and created a fresh environment. Try install a lower version of Rasa X or even try to install rasa open source. Share the error screenshot

@nik202 yes I have tried all those things. Error is there still. Same error that I have shown earlier.

@rhazra-003 can you in brief type the steps you are following?