How to install Rasa X 1.0.1 on GCP - VM?

Hi there!

I’ve a GCP VM with ubuntu 20.04. I’ve a git project which worked well with rasa X 0.42…

Now, I try to install Rasa X 1.0.1 with rasa open source 2.8.11 and I need some help:

1º Created a root password and became su;

2º installed RASA Ephemeral

3º cloned my github project “catiaV2”

4º Rasa status is:

Name:                           nervous-wu                          
Status:                         Running                             
URL:                            http://ip:30043         
Version:                        1.0.1                               
Enterprise:                     inactive                            
Rasa production version:        0.0.0                               
Rasa worker version:            0.0.0                               
Project path:                   /home/antoniopedrolopes/proj/catiaV2

5º I can run rasa-x on browser & connect with catiaV2 project on github, but it won’t let me train a model;

6º I installed rasa open source 2.8.11 with “Step-by-step Installation Guide”

7º I did source ./venv/bin/activate

8º My command line is “(venv) [email protected]:/home/antoniopedrolopes/proj#”

9º I run “rasactl connect rasa” & it gives me this error:

(venv) [email protected]:/home/antoniopedrolopes/proj# rasactl connect rasa
●∙∙ Upgrade has beed finished, status: deployedpanic: interface conversion: interface {} is nil, not map[string]interface {}
goroutine 1 [running]:
github.com/RasaHQ/rasactl/pkg/k8s.(*Kubernetes).GetRabbitMqCreds(0xc0003e9580)
        /go/src/rasactl/pkg/k8s/secrets.go:127 +0x23a

Can someone help me?

@nonola sure,well I still not upgraded from 0.42.5 to 1.0.x, but can you share the screenshot when you train what message you are getting? are you traing with rasa x or with github? (github actions).

@nik202 trained on rasa x and its failed. And the connection with rasactl gives me the error above.

@nonola check that git or github is connected?

@nik202 yes, and all the data apears correctly.

@nonola Hello there! :wave: Which version of rasactl are you running?

$ rasactl --version
rasactl version 1.0.1

Try with the latest version, if that doesn’t work, try again with a new deployment.

Hi @virtualroot , yes, I had version 1.0.1. I’ll try with a new deployment.

@virtualroot : i create a new VM, running ubuntu 20.01;

My project is on github;

My rasactl status:

(py38) [email protected]:~$ rasactl status
Name:                           rasa-x                   
Status:                         Running                  
URL:                            http://ip:30013
Version:                        1.0.1                    
Enterprise:                     inactive                 
Rasa production version:        0.0.0                    
Rasa worker version:            0.0.0                    
Project path:                   not defined    

My rasa open source version:

(py38) [email protected]:~$ rasa --version
Rasa Version      :         2.8.14
Minimum Compatible Version: 2.8.9
Rasa SDK Version  :         2.8.4
Rasa X Version    :         None
Python Version    :         3.8.12
Operating System  :         Linux-5.11.0-1028-gcp-x86_64-with-glibc2.17
Python Path       :         /home/antoniopedrolopes/anaconda3/envs/py38/bin/python

I could connect rasactl with rasa, I did the training in rasa x, the conversations work, but the actions are not executed. (the action is detected on rasa-x conversation, but not executed…)

Did I missed something? Do I have to have some values.yml file?

Thanks a lot!

@nik202 can you give-me a little help with this issue?

Thanks!

@nonola one and only one solution downgrade the rasa x 1.0.1 to rasa x 0.42.5 while using the older installed method or if you want to install with this method go ahead but try to use the older model.

@nonola sorry for not getting back to you early on your issue before.

1 Like

@nonola any update?

Hi @nik202 ! I did what you told me and it worked. Maybe it’s too soon to move to rasa x 1.xxx or rasa open source 3xxx.

Thanks a lot!

@nonola nice:slight_smile: glad it helps you.

1 Like