How install newest rasa sdk version

when i run rasa run actions command it getting this userwarning UserWarning: Your versions of rasa and rasa_sdk might not be compatible. You are currently running rasa version 2.7.1 and rasa_sdk version 2.5.0. To ensure compatibility use the same version for both, modulo the last number, i.e. using version A.B.x the numbers A and B should be identical for both rasa and rasa_sdk. warnings.warn( could plz tell me how to fix this…thank you

I ran pip install rasa-sdk~=2.7.0.then it updated rasa sdk .now the warning is not displayed .but there another user warning comes c:\users\dell\appdata\local\programs\python\python38\lib\site-packages\rasa\shared\utils\ UserWarning: the value of ‘evaluate_every_number_of_epochs’ is greater than the value of ‘epochs’. No evaluation will occur. ***how to fix this

In your config, you have in either DIET, Response Selector, or TED, evaluate_every_number_of_epochs greater than epochs.

If not, just add evaluate_every_number_of_epochs: 1. For example:

- name: DIETClassifier
  epochs: 140
  evaluate_on_number_of_examples: 200
  evaluate_every_number_of_epochs: 5 # <-- must be smaller than epochs
  tensorboard_log_directory: ./.tensorboard/DIET
  tensorboard_log_level: epoch

And check this is the case for DIET, Response Selector, and TED.

1 Like

Problem solve thanks a lot :pray: :pray: :pray: :+1: :+1: @ChrisRahme

1 Like