Epoch Value

I get this warning when I run ‘rasa shell’ and in return, my custom action messages don’t get displayed.

UserWarning: the value of ‘evaluate_every_number_of_epochs’ is greater than the value of ‘epochs’. No evaluation will occur.

Can someone please help me to solve this?

@prajaktaghorpade can you share your config.yml file? did you mention under DIETClassifier or can be in TED Policy evaluate_every_number_of_epochs greater than epochs , try to train the model with fewer epochs and not greater than original epochs.

For more detail please check this blog Tensorboard in Rasa

It will solve your issue. good luck!

1 Like

config.yml (1.4 KB)

I have uploaded my config.yml file. I have mentioned nothing about evaluate_every_number_of_epochs in it. Should I mention it the way it is mentioned in that blog?

@prajaktaghorpade really :face_with_monocle: you’re config.yml is perfect. Did you mention before? No, you not need to update if you not required.

What do you mean by this “my custom action messages don’t get displayed”? can you post the screenshot of error please.

Division by zero, array index out of bounds and segmentation fault are the entities that I am extracting for my custom actions. I am running rasa run actions in the in another prompt. I receive no reply for these entities, and initially it worked. But for some reason, the second time I runned it, I got this warning and I received no reply. I made no changes between the first and second time.

@prajaktaghorpade its just a warning mate. You scared me. Try delete the older train model and train again. Even check the log of action server, you will find your error. I guess you will be fine. If not me here :stuck_out_tongue:

Heyyy, I am so sorry to disturb you again @nik202 But can you tell me how to get rid of this warning? There is no error on my action server and I deleted a bunch of older train models and it still isn’t working. All I know that ever since I got this warning, my chatbot isn’t running as it did before.

@prajaktaghorpade can you set the zoom meeting?

Sure thing! But I am currently a lil bit occupied, would you be available tomorrow? Let me know the timings in which you’re free. Thank you so much for your help!

@prajaktaghorpade in evening GMT I’m free at 4pm.

1 Like

@nik202 how did you fix this error?

@TomilinWow Is this error disturbing your chatbot? If not I guess just ignore its just a warning.