Guest conversations flickering/refreshing constantly

Hi there.

I installed Rasa X 0.28 yesterday and it seems to be working in the main, however, when I try and get a guest link to send to people to converse with my bot, I see the page load as expected and the Rasa logo briefly appears, and then it says “You have been invited to have a conversation with an AI assistant” and then immediately that changes to “You have been invited to have a conversation with Test” (Test being the name I chose) and then back again to “an AI assistant” over and over forever.

If I open the same URL from the same browser as I’m logged in to Rasa X with it works as expected.

If I look in developer tools there’s two calls being made which are shown in red - one that says “ClientNotFound” and the other being an authorisation failure.

XHR 9cd76e76-ec98-4fa7-9c4c-a04ed9313e15?since=0&environment=production
{"version":"0.28.0","status":"failure","message":"Client for conversation_id '9cd76e76-ec98-4fa7-9c4c-a04ed9313e15' could not be found","reason":"ClientNotFound","details":{},"help":null,"code":404}


XHR 9cd76e76-ec98-4fa7-9c4c-a04ed9313e15
{"reasons":["Auth required."],"exception":"Unauthorized"}

I’m running Rasa X behind an nginx reverse proxy. Where should I be looking to get this tracked down and fixed please?

1 Like

exactly the same (i tried with multiple browsers ans OS). also another bug : impossible to save the responses in the interface. I did not analyse futher but seems to be a http401 error also. Let’s wait for a solution as both problems are probably linked.

1 Like

I see 0.28.1 was just released. Upgrading to that now to see if it fixes it.

1 Like

I’m afraid not. Now I don’t have the button to create a guest link at all?

I’m wondering if it has to do with the credentials.yml in the repo for my bot? That mentions that it needs to be configured to work with Rasa X but I don’t know what the correct value should be?

It’s currently:

# This entry is needed if you are using Rasa X. The entry represents credentials 
# for the Rasa X "channel", i.e. Talk to your bot and Share with guest testers.
  url: "http://localhost:5002/api"

which is I believe the default?

I have re-done a full clean install of the ubuntu VM with 18.04, gave 4 CPU, 10 GB ram and 60 GB disk, then ran updates then ran one-line deploy.(v0.28.2) When I run kubectl get pods, I get this

Then I tried to delete all the pods and re-create, I tried to make kubectl drain / kubectl uncordon … but the 2 pods remain offline and in CrashLoopBackOff status.

I have done “kubectl cluster-info dump” and I have a huge file. I could not for sure pinpoint the problem. I continue on searching but if somebody with more k8s skills could have a look, it would be so nice …

NB : symptoms remain the same : impossible to create the first conversations (sharing link not working) / impossible to save responses / to train a model / to upload a model.

I have a similar issue with Rasa-x 0.28.2 (latest version) on Docker + Nginx. The interface flickers on several browsers. It seems to be an authorization problem when trying to keep contact with the rasa-x api.

The network analysis in the browser returns this: Request URL: .../api/conversations/1283d80d-6f25-4c9e-92a5-bc8a503ba7f6/tracker?since=0&environment=production

Response: {"version":"0.28.2","status":"failure","message":"Client for conversation_id '1283d80d-6f25-4c9e-92a5-bc8a503ba7f6' could not be found","reason":"ClientNotFound","details":{},"help":null,"code":404}

Nginx container log is this: - - [08/May/2020:09:21:39 +0000] "GET /api/conversations/64c26ee6-07a7-4f16-9c23-3874d4986e51/tracker?since=0&environment=production HTTP/1.1" 404 198 ".../guest/conversations/production/38218f310cde48ae9ed4c0efdf76b96e" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36"

I can stabilize the interface by opening the flickering page. Hitting the home button of my Firefox browser, and then reloading the page. It is visible then and works fine. I realized that my session in rasa-x ends after I do this (i.e. I get logged out). Edit: Another weired thing is that the guest link I can generate is always the same one. I would expect that the generation produces unique links each time.

Thank you for the trick. It stops the fickering in some cases (OK in Firefox, but not in private mode).

The conversation does not run normally for me however. The text just disappears when I click on “send”. Probably because my 2 pods remain offline. So this is another issue and I will investigate it separately.

I hope the RASA team will sovle the flickering issue anyway as I would not dare to give a flickering interface to my users explaining they have to hit home and refresh to make it work … :-/ (by the way it did not work on Chrome and Opera)

I upgraded to 0.28.2 and the Share button has reappeared, but I still have the flickering.

I’m using docker-compose on Ubuntu 18.04 - not Kubernetes .

Hey I succeeded to make it work ! everything is OK now.

Steps I took :

-after install, do not forget to put the extra line export KUBECONFIG=/etc/rancher/k3s/k3s.yaml in the .bashrc file of your user (important)

-I ran “sudo kubectl get pod --namespace rasa” to have the list of the pods

-there you can note the name of the pods and the status. In my case the 2 following pods had a status “crachloopback” : rasa-rasa-worker and rasa-rasa-production. (no more on this printscreen as it is done after solving the issue :slight_smile: )

-type then "sudo kubectl describe pod rasa-rasa-production-xxxxx-yyyyy --namespace rasa "(you can find the exact numbers xxxxx and yyyy of your install in the previous command)

-in the describe, I found the error exit code 132 . After looking it up in the docs, it appears to be an error for non supporting SSE4.2 processor instructions.

-back to my hypervisor, I shutdown the server VM, changed the default emulated processor type to passthrough core i5 8xxx (take any recent processor supporting SSE4.2) and restarted. It then works perfectly for me (flickering is gone, upload model works back, …). NB : if you have just an old CPU (before 2010 more or less) then SSE4.2 will never be supported unfortunately due to hardware limitation.

maybe there are other possible causes but the use of “sudo kubectl describe pod …” will give you the error code you can search for. NB : I have tried with docker-compose also and the problem was exactly the same. So it might also be solved by editing the CPU type. But I did not have a look at error codes.


As I say I don’t use Kubernetes. I still have the problem I reported originally. Everything works fine for me (bar some niggles) except the guest sharing link. None of my Docker containers are crashing. They’re all running as expected but the UI still doesn’t work.

Hey everyone, we’re aware of the flickering on share your bot, and working on a fix. In the meantime, usually a hard refresh (shift+cmd+R) takes care of it (but obviously this may be tedious because the guest user has to do it)

1 Like

Maybe are some news about fix? We have same error after update.

Edit. we roll back to 27.8 version, problem for now fixed

How can I roll back to a lower version

Thanks ,Man ,It solves almost flickering and incomplete message problems by deploying in kubernetes and adding config files as you said…initially it did not show any flickering and then after sharing with one or more two started again…

Changing cpu types …Do you mean N1(First generation) to E2 (second generation) or upgrading N1 2 cpu to N1 8 cpu

Package Index rasa-x-0.27.8.tar.gz delete old, install this one. Or u can just edit script RASA_X_VERSION=${RASA_X_VERSION:-0.27.8} and run one line install with kubernetes