FAQ chatbot with wrong intent classification and no response in Rasa X?


I started out with the rasa init project, mood_text_bot, and then customized it for our FAQ-based chatbot.

Our FAQ questions are listed as faq/1 through faq/50 and the corresponding answers are listed through utter_faq/1 through utter_faq/50. When I launch the rasa X conversational user interface and ask the exact same line of question that is in one of the FAQ’s, the intent is still not classified as the matching question. Then, when I manually try to replace it to the correct question intent, (I can see all the intents of our FAQ from within the Rasa X user interface), the response is not happening, and I get an error within VScode Rasa X terminal bash that the faq/17 is not in the list. " An unexpected error occurred. Error: ‘faq/17’ is not in list"

So I removed all lines of question and answer pairs that would be part of the mood_bot_text project, retrained the model, and relaunched the RasaX. the error repeats.

my domain, config, and nlu.yml files are as simplest as it could be. Where could the mistake be?

Regards, Tamer

1 Like

Hi Tamer! Sorry for the late reply! Please let me know if your question is still up to date.

Have you tried to create new training data item from your conversation in rasa x? (from the conversations screen → click on the part of the conversation and then → “save to training data”) or did you play around with the interactive learning in rasa x a bit? not sure if that helps.

Maybe if you’re still facing the problem you can share screenshots?

1 Like