Facebook Messenger to RASA postback from Button click not working

I’m working on Facebook integration with RASA. It’s working fine as normal for request and response by typing. As further, I start to put some button and other facebook generic templates to replace the typing. I’m able to display the response in messenger with click button. But as I try to click the button, it has no effect to bots. I also check the logs but nothing happen. It’s a postback type button, and payload is one of my intent. No matter how many click on button it still not working, but if I type, it work as normal.


Hey there, which version or rasa or rasa_core is this on?

@erohmensing My Rasa Core version is 0.13.4 Could it be the problem of version ?

I now move to Version 1.0.1 with response using “dispatcher.utter_elements” instead of “dispatcher.utter_custom_message”

It’s still not working, something must be missing here

Hm okay yes this is strange. Are you hooked up to ngrok – if so, can you see the button click coming into the webhook?

Also, this shouldn’t fix the problem, but just letting you know that your payload should acutally be “/affirm” instead of “affirm” if you want it to map directly to the intent.

On Local Ngork, there is no input going in/out Also I modified my intent to be /affirm.

If I try with RASA Button on Terminal, it worked but switch to Messenger Button it’s not working. Could it be the problem of post call-back ?

Can you let me know if the same error happens if you define buttons from your utterance templates? I’m wondering if this issue is affecting buttons, custom json payloads, and elements all together.

Anyone resolved this issue yet? I’m encountering issue once user is clicking on the like button as reply in Messenger. My bot won’t reply.

It has been too long since the question but for ones come this post laterly. One cause that makes postback button can’t work is you have not subscribed necessary field ( in Facebook app dashboard → Messenger → Settings)

@sysang … still no success :confused: