Error in data / new since version 0.22.0

Hello, Since I updated RasaX to version 0.22.0 I have had an error in the data / new section that I can see in my browser console.

Attachment screenshot

Could you tell me how to fix it please?


1 Like

Hi, I have updated to the new version [0.22.2] - 2019-11-08 but the error continues. I hope you can help us. I remain attentive to any additional information you need. Thank you

1 Like

Hey there @rcucala. Sorry we didn’t get back to you so far but good to know you have already tried the newest version to see if that solved the error. Two pieces of info would be helpful:

  1. What are you trying to do when you receive this error?

  2. Can you check the Network header when you try to do whatever number 1 is (if it happens right when you hit the page, then you’ll have to refresh to see the network request) and see if anything is funky there?

Are you trying to add new data without a model active? I know that is a similar situation where I have run into an error on that page.


Hi, @erohmensing thank you very much for the answer :slight_smile: The error always occurs when I access http: // myhost / data / If I access the rest of the sections such as http: // myhost / data / training-data or http: // myhost / data / lookup They load ok and do not generate errors. If I check the network resources loaded in the browser, they all give 200 OK and 404 errors do not appear. I attached a screenshot. We have an active model. He tested with several models and from different browsers and the error continued. The rest of the sections work correctly, it only happens in / data or / data / new I look forward to it :slight_smile: Thank you

1 Like

Okay this is helpful, thanks! What does that /data page look like when the error appears, and what sort of broken functionality are you seeing as a result of it?

1 Like

OK, thanks for answering @erohmensing :slight_smile: the screen appears blank, no errors appear. Only the console error appears: 2.ec6f97dd.chunk.js: 1 TypeError: Cannot read property ‘set’ of undefined at Function.r.applyStyle (2.ec6f97dd.chunk.js: 1) I have deleted the browser cache and tested from several browsers (chrome, firefox, safari) and in all the blank screen appears and the same error in the browser console.

In addition, no errors appear in the network section in any of the browsers.

Thanks for the help :slight_smile:

Any suggestions please? Thank you!

Hi! In version 0.23.0 this problem has been fixed. Thank you very much!

Amazing. Sorry for not getting back to you! Had to send it off to a front-end engineer and forgot to come back to this :slight_smile: