Rasa X console won't train new model... thinks "nothing has changed"

Version: 0.27.4

Hi everyone :slight_smile:

For some reason when I click “train” on the Rasa X console it tells me “Nothing has changed: It seems no changes were made to your model, so we skipped training a new one!”

I’ve added stories, responses, and entities, and did some interactive learning since the last model was trained. I also tried deleting the most recent model. Still getting the same message.

Any ideas?

1 Like

I think this is an issue with the client code rather than with the bot.

I have had the exact same problem …

We have exactly the same problem too.

In Chrome’s “Developer Tools”, you can inspect the actual training request to /api/projects/default/models/jobs.

Rasa X says “nothing has changed”, but that’s not the real error. In our case, if we inspect the API response, the server is returning a “500 Internal Server Error” and reporting an inconsistency in our domain.yaml file.

Likely there is nothing here for the Rasa team to fix. They just need to improve the error messaging on the UI in order to reveal the real error.

1 Like

+1 to this being an error messaging issue. I realized I had a handful of bugs and leftover training data from previous iterations. I started over, copying over only the training and domain data I needed based on my latest bot setup. After a thorough debug Rasa X started letting me train models again.

Thanks for the info @intranetchris ! Where do I put ‘/api/projects/default/models/jobs’? I tried putting it at the end of my Rasa X instance and in the google developer tools console but neither worked.

@captain-curious See screenshot. In Chrome, open Developer Tools. Make sure (A) Network tab is selected. Press (C) Train. The API request will show up at (B). Right-click to copy the response and paste it somewhere where you can study it.

Hope that helps. Welcome to the Rasa QA team. :roll_eyes: For every hour you spend on your model, expect to spend 4 hours figuring out why Rasa isn’t working. That’s our experience…


Helpful. Thanks!

I am having the same problem… but looking at the response doesn’t really help. Any advice on where to look next?

Status Code: 500 Internal Server Error