Empty Response from Rasa running in Docker

Not running Rasa X Rasa version 1.10.0 pip installed with python 3.7.5 Using Docker Desktop for mac, version Mac OSX 10.15.3

When running rasa on my local, I can curl the service with webhook of the form

curl localhost:5005/webhooks/rest/webhook -d '{"recipient_id": "default", "message": "Hi!"}',

and I’ll get a response.

However, when running in docker with port exposed, I get an empty array as a response

The service can be curled while running in Docker from my local in other respects such as curl localhost:5005/ will return the expected rasa hello response with version.

How I run:

Run commands take the form (simplified to ignore things like env variables that pertain to actions server):

docker build . -f NLP.Dockerfile -t rasa_nlp_test

docker run --name rasa_nlp_test_run -p 5005:5005 rasa_nlp_test:latest rasa run


FROM python:3.7.5-slim
WORKDIR /home/server

RUN apt-get update && \
    apt-get -y install gcc && \
    rm -rf /var/lib/apt/lists/* && \     
    pip install --upgrade pip 

ADD requirements.txt /home/server/requirements.txt

RUN pip install --no-cache-dir -Ur requirements.txt

ADD . /home/server
RUN export PATH=$PATH:~/home/server
EXPOSE 8080/tcp

When I docker exec... into the running container I can see that all the directories are there that I might expect, including the models folder which is populated.

hey, did you find a solution for this? i am facing the same error! whenever i am running in local, it return response properly but when i deploy in docker, an empty array is returned

hey have u found the solution i am also getting an empty array… i am using docker toolbox windows…