Don't receive message reply on slack


I’m newer with Rasa stack. I build a simple rasa chatbot and integrate it with the slack channel. Following the tutorial, I’ve added URL: https://xxxxxx/webhooks/slack/webhook to the Event subscription, which has been verified through both ngrok and rasa server, as shown below:

POST /webhooks/slack/webhook 200 OK

2018-12-07 20:34:04.861505: I tensorflow/core/platform/] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA - - [2018-12-07 20:34:10] “POST /webhooks/slack/webhook HTTP/1.1” 200 200 0.000759

Also I can ensure both ngrok and rasa server are running on the same port.

However, I still can’t receive any replies from my rasa bot. Does anyone have ideas why it happens?

Thanks a lot, Yanchao

Hey @yanchao_yu. What output do you get on ngrok and rasa server when you send a message on slack?

Hi @Juste I am also facing the similar issue when i use @appname as slack_channel in credentials.yml. Please see the issue i raised

Hi @aggarwalrahul86. There are clearly some issues with the connector at the moment, which I am going to look into in more detail. Right now, looks like that your app name != slack_channel because you should get the responses to direct messages if you leave the ‘slack_channel’ parameter out. Give it a try without this parameter. In a mean time we will look into what’s up with the connector (there are some PRs being worked on already)

Thanks a lot @Juste , It worked without slack_channel parameter.

@Juste was this fixed in the recent releases ? If not is there a format or pattern to when it works and when it does not?

Best wishes,


Hello Juste,

Sorry for the late reply. I was just back from business trip. I think I’ve solved this problem.


1 Like

Hey @mark_collins the app mention was fixed in the most recent release so it should work well now

@Juste Can you tell me what the change was that fixed it? I’d like to have a look at the code to confirm it is fixed in the current build. :slight_smile: Thanks!


Hey @mark_collins. Here is a PR that was merged to enable app mentions

1 Like