Deploying Docker-Installed Rasa X to Facebook/Slack. How to find port of server?

So I am trying to deploy Rasa X onto a facebook page and slack as an app but I have some problems I ran into and need help answering.

I was able to already integrate a version of Rasa on facebook and slack when it was locally ran. But with the docker compose quick install method I have some trouble trying to find its endpoint for the https URL. I am using ngrok to do this and normally how I did it with the locally ran Rasa I would

$rasa run --credentials credentials.yml

this way I can then use

./ngrok http **port**

and recieve the https url so that I can add the endpoint for the app in FB/Slack. But since with the docker version of rasa anytime you try and run a rasa command such as

rasa run

then I would just recieve:

rasa: command not found

So is there another method to find out the port the server is on to get its https url?

Ubuntu 18.04

But with the docker compose quick install method I have some trouble trying to find its endpoint for the https URL.

Did you actually enable HTTPS by providing certificates? Otherwise Rasa X is gonna be available on port 80. Note that the docker-compose setup as nginx as reverse proxy in front of the setup, so your URL would be something like http://<host of your machine>:80/core/webhooks/facebook/webhook (the core part is because of the reverse proxy)

I did enable the https and so on. But when I try to run ngrok in the port 80 it then connects to my literal local machine (since i am connected to a server using the ssh command) which i know since it shows my username.

ill try this tommorow since i never tried adding core to the url.

Hey @Tobias_Wochinger I was not able to make it work, I am looking for the rasa url in rasa-x server, I have used docker-compose for rasa-x installation.

I was trying to hit the status endpoint using http://my-rasa-x-domain/core/webhooks/rest?token=my- token Same is true for rest channel http://my-rasa-x-domain/core/webhooks/rest/webhook?token=my-token

I am getting 404

though I am able to hit my-rasa-x-domian/core/status?token=my-token

I have updated credentials.yml and added rest:

@Tobias_Wochinger I was able to to make it work by simply adding the rest: in credentials.yml

1 Like

hello @madanmeena have the same problem but with telegram can you help me ?

@M_R_LY My issue was resolved when i added rest: in the credentials.yml file. Not sure it will help with yours, for each channel we need to create an entry in credentials.yml, we are basically using rest and callback channel, as we are not routing the traffic directly to rasa, so rest channel were sufficient for our use case.