Custom connector error

RasaException: Failed to find input channel class for ‘my_connector.RestInput’. Unknown input channel. Check your credentials configuration to make sure the mentioned channel is not misspelled. If you are creating your own channel, make sure it is a proper name of a class in a module.

I am getting this error while running my custom channel. Can anyone please help? It’s running fine on rasa shell but while running cors I am getting this error.

@Ashish15 Can I asked which channel you are using?

Even If you can share your credentials.yml file.



  url: "http://localhost:5002/api"

  username: “user_name” if you have then only

@Ashish15 in

    def name(cls) -> Text:
        return "rest"

yes…tried that as well…still getting the same error

@Ashish15 I haven’t see your other two files can you please upload again.

credentials.yml (806 Bytes) (5.5 KB) (1.3 KB)

uploaded…are u able to find them now?

tried…yet not working

@Ashish15 same error huh strange? :frowning:


Be sure to run the rasa api in the same directory where the connector file is.

that’s where i am getting the error sir

Hello, I’m replying to an old topic but I might have figured out the problem today. When you use rasa run with --debug, there will be more messages on top of the Failed to find input channel class.

In my code it is: no module named ‘motor’ refer to this package: Motor: Asynchronous Python driver for MongoDB — Motor 3.1.1 documentation

I have installed it and the error goes away.

1 Like

Absolutely. This failure can arise if the channel is unable to be loaded due to missing imports of modules or other errors in the code.