Contradictory error messages with rasa 2.0 regarding multidict

Hello, I am new to using Rasa and I’m not able to figure out what to do with these errors messages which seem to contradict one another.

First I received these errors:

rasa 2.0.2 requires multidict<5.0,>=4.6, but you’ll have multidict 5.0.0 which is incompatible aiohttp 3.6.0 requires multidict<5.0,>=4.6, but you’ll have multidict 5.0.0 which is incompatible

So I installed multidict 4.6 to try to resolve this issue, but then received this error in turn:

sanic 20.9.1 requires multidict==5.0, but you’ll have multidict 4.6.0 which is incompatible

It seems there’s a paradox where I need multidict to simultaneously be equal to 5.0 yet also less than 5.0. Am I misinterpreting something? How can I resolve this?

Hmm, this does seem like an error. Can you file an issue? (Issues · RasaHQ/rasa · GitHub)

In the meantime, I’d downgrade Sanic. I just did a fresh install and have Sanic 19.12.2 & Rasa 2.0.3 working locally for me.

Hi,

I am facing the same issue where I get the below message:-

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

rasa 2.0.2 requires multidict<5.0,>=4.6, but you’ll have multidict 5.0.0 which is incompatible. aiohttp 3.6.3 requires multidict<5.0,>=4.5, but you’ll have multidict 5.0.0 which is incompatible.

Could you please guide me the steps that you followed to resolve this issue in your local.

Thanks in advance.

Regards, Ayush

The pip error is due to a pip update & not on the Rasa side.

The other two errors are about having too recent of a verison of multidict. I’d downgrade to 4.6.

pip install multidict==4.6
2 Likes

Thanks for your reply. It now work but I am getting a lot of errors where I am trying to run RASA X on my system.

Below are the error messages that I am getting:-

Could you please assist how can I resolve this.

Thanks in advance.

Regards, Ayush

There’s something wrong with your stories. Could you start a new question w/ more details? (And just in case it’s helpful, since I see you’re new to the forums, you can find tips on asking questions in a way that makes it easier for people to answer here: How to ask a great question)

1 Like

Step 1 - Downgrade the sanic

pip install sanic==19.12.2

Step2 - Downgrade the multidict

pip install multidict==4.6

This works for me.

1 Like

also if you have problems with numpy, install 1.16.0 version

pip install numpy==1.16.0