When installing Rasa X with the following Pipfile:
Get the following error:
ERROR: Could not find a version that matches multidict<5.0,<6.0,<7.0,>=4.5,>=4.6,>=5.0 (from rasa==2.3.1->rasa-x==0.36.0->-r
It seems rasa-x==0.36.0 requires rasa==2.3.1 which requires multidict<5.0,>=4.6 but also rasa-x==0.36.0 requires sanic==20.12.2 which requires multidict<6.0,>=5.0
Obviously, you can’t have multidict<5.0 and multidict>=5.0.
When attempting to install with pip instead of pipenv:
python -m venv .venv .venv/Scripts/activate pip3 install rasa-x --extra-index-url https://pypi.rasa.com/simple
sanic-jwt 1.6.0 requires pyjwt==2.0.0, but you'll have pyjwt 2.0.1 which is incompatible. aiohttp 3.7.3 requires chardet<4.0,>=2.0, but you'll have chardet 4.0.0 which is incompatible. sanic 20.12.2 requires multidict<6.0,>=5.0, but you'll have multidict 4.7.6 which is incompatible. python-socketio 5.0.4 requires python-engineio>=4, but you'll have python-engineio 3.13.2 which is incompatible. rasa 2.3.1 requires aiohttp<3.7,>=3.6, but you'll have aiohttp 3.7.3 which is incompatible.
Does RASA X have dependencies which are incompatible with each other out of the box?